More info on: irq problem with pcmcia-cs-3.1.33 & orinico

Vic Berdin sndbeat at
Tue Mar 12 18:45:56 EST 2002

Hello Everyone,

This is an update on my previous message yesterday. I
forgot to include the exact errors displayed on my
screen as I get IRQ problems.

Anyways, the messages are as follows:

MSG 1> orinoco_cs: RequestIRQ: Resource in use
Above message pops up when the orinoco_cs module
detects that IRQ 10 is in use. And still, it kept on
using IRQ10 (see previous message below).

This message appears when the orinoco modules loads
and raises eth4 properly (but still using IRQ 10), and
I'm able to make use of the wireless connection.

MSG3> eth4: Null event in orinoco_interrupt
This message keeps on showing when the orinoco modules
succesfully loads and raises eth4. This message simply
keeps on popping out continously as long as I have
eth4 "up".

Any help on making the orinoco modules make use of
other IRQs is greately appreciated. I don't mind even
if I have to explicitly declare them on the source
codes. Just tell me what value, and where to place
them. My available IRQs are: 3,5,7, & 9 respectively.
If possible, I would like to make use of 9 for my
wireless interface.


Message: 9
Date: Mon, 11 Mar 2002 03:08:03 -0800 (PST)
From: Vic Berdin <sndbeat at>
Reply-To: sndbeat at
Subject: irq problem with pcmcia-cs-3.1.33 & orinico
modules in Debian 
To: wireless at

Hello Everyone,

I'm having intermittent problems making my prism II
compatible, and Lucent Orinoco silver cards work
smoothly on my Debian 2.2.19 box. My problem is that
card manager keeps on using a non-available IRQ (irq
10 to be exact) for my wireless cards. Below is a copy
of my /proc/interrupts file:

  0:     344565          XT-PIC  timer
  1:        819          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  4:        668          XT-PIC  serial
  8:          2          XT-PIC  rtc
 10:       2362          XT-PIC  eth0
 11:         57          XT-PIC  eth1
 12:         57          XT-PIC  eth2
 13:          0          XT-PIC  fpu
 14:      18113          XT-PIC  ide0
 15:         57          XT-PIC  eth3
NMI:          0

Notice that my box has 4on-boards eth devices, where
IRQ 10 is already being used by eth0. As a futile
solution, I've already tried listing all non-available
IRQs in the exclude lines of /etc/pcmcia/config.opts
file, and also added a PCIC_OPTS="irq_mode=5" on my
/etc/pcmcia.conf file. Actually, I've tried all
available irqs as values for the irq_mode parameter.
But still, card manager kept on insisting that IRQ 10
must be used.

What puzzles me further is that, there are also
numerous times when the card manager successfully
loads all modules (hermes, orinoco, orinoco_cs), and
manages to raise an "eth4" interface for the wireless
device. And when this happens, everything seems to
work very well. I can ping, ftp, surf, etc. using the
wirelss interface. Here's a copy of my iwconfig result
on eth4 once the module successfully loads:

eth4      IEEE 802.11-DS  ESSID:"workgroup"
Nickname:"Prism  I"
          Mode:Managed  Frequency:2.422GHz  Access
Point: 00:02:2D:02:8F:EF
          Bit Rate:11Mb/s   Sensitivity:1/3  
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:92/92  Signal level:1/153 
Noise level:108/153
          Rx invalid nwid:0  invalid crypt:0  invalid

Link quality is even excellent! How can I make the
above iwconfig result more permanent? Thanks very much
in advance.


Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!

More information about the wireless mailing list