Jim Carter jimc at
Sun Apr 21 15:03:54 EST 2002

On Fri, 19 Apr 2002 21:14:25 -0400, Pavel Roskin <proski at> wrote:
> > So I edited /etc/pcmcia/orinoco.conf to say:
> >     include irq 5
> >     module "orinoco_cs" opts "irq_list=5"

> I doubt that you need it.

> Please try the "irq_mode" option for the socket driver (I believe it's
> i82365 in your case).  Read "man i82365" for details.
> You can set this option in /etc/modules.conf:
> options i82365 irq_mode=0

Thanks very much for your help.  As I am using kernel PCMCIA, I tried
various ineffective maneuvers to get an equivalent effect.  Kernel
PCMCIA always uses the PCI IRQ if it's known, which it is (equivalent to
irq_mode=0).  I tried doing

	setpci -v -s 2:3.0 INTERRUPT_LINE=5

(that's the slot for the wireless card), and something stayed set to 5,
but reloading the modules, or rebooting, still assigned IRQ 11 to the
card. lspci reported no change in IRQ.

However, I used the inverse technique, to just unload all competing
drivers, so the only things on IRQ 11 are the PCMCIA slot controllers
themselves and orinoco_cs.  Data transfers speeded up by 2%, i.e. I'm
now getting 25.6 Kby/sec :-)  Probably just chance variation.  There
was a "Tx excessive retries" on every packet.

I also got pcmcia-cs-3.1.33 and caused its drivers (orinoco v0.09b) to
be loaded, minus all competition.  The behavior was identical.  So I
conclude that no matter how suspicious the interrupt sharing is, it's
irrelevant to my problem, as you said.

On the partner machine, orinoco_plx shares an IRQ with usb-uhci which is
completely idle (until I turn on my printer).

Does anyone have any other ideas to try?

James F. Carter          Voice 310 825 2897    FAX 310 206 6673
UCLA-Mathnet;  6115 MSA; 405 Hilgard Ave.; Los Angeles, CA, USA  90095-1555
Email: jimc at (q.v. for PGP key)

More information about the wireless mailing list