[Samba] Possible memory leak in

Matt Oursbourn moursbourn at gmail.com
Thu Sep 9 23:48:29 UTC 2021

I am very new to linux.  I dove into this less than a month ago.  I was
going to try to compile the code from the samba web site but I didn't
really get through all of the instructions.

  I tried to install from  https://apt.van-belle.nl/
I couldn't get that to install either..  Someone was trying to help on
reddit here:

I did everything in the quick setup instructions at:

Seems like the only place to screw up is:

sudo echo "deb http://apt.van-belle.nl/ubuntu focal-samba414 main contrib
non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list

..but I think I edited that line correctly.

When I got to the end and ran: sudo apt-get install -t o=AptVanBelle samba

I thought that was supposed to force the install from the repo but it
doesn't. I get this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
samba is already the newest version (2:4.11.6+dfsg-0ubuntu1.10).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

Obviously that isn't getting version 4.14.7. I looked into the apt pinning
but I am not understanding how to get that working in Mint. Now I am stuck
and I don't know what I don't know to make this work.

this is my output for: apt-cache policy samba

    Installed: 2:4.11.6+dfsg-0ubuntu1.10
    Candidate: 2:4.11.6+dfsg-0ubuntu1.10
    Version table:
*** 2:4.11.6+dfsg-0ubuntu1.10 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
    2:4.11.6+dfsg-0ubuntu1.8 500
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
    2:4.11.6+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

It was suggest that I purge samba first so I did this:

sudo service smbd stop
sudo apt --purge remove samba
sudo apt-get install -t o=AptVanBelle samba
samba -V

and I seem to be right back where I started: Version 4.11.6-Ubuntu

On Thu, Sep 9, 2021 at 2:50 PM Andrew Bartlett <abartlet at samba.org> wrote:

> Thanks Matt for getting in touch.
> On Thu, 2021-09-09 at 14:38 -0700, Matt Oursbourn via samba wrote:
> > Hello.
> >
> > I have an issue where samba is not freeing memory. When I start a
> > large
> > file transfer over a 10Gb network samba jumps up to 20+GB ram usage
> > pretty
> > quickly. Eventually It fills up all ram and swap and the kernel kills
> > Samba.
> ouch, that isn't good.
> > I can't figure out how to install samba-4.14.7 from the samba website
> > to
> > test it.
> You may want to try the packages that Louis publishes here:
> https://apt.van-belle.nl/
> Also, it would be great to check if a master build from source still
> fails.
> However ideally you would know what version last worked without a
> memory leak, and build samba 4.14.7 form source do a git bisect (of
> source builds) in between to find the regression.  It could take some
> time, but is a brute-force way to help us help you.
> We did have a memory leak in some crypto code (the leak was in gnutls
> actually) but I don't think that was in 4.11.
> Andrew Bartlett
> --
> Andrew Bartlett (he/him)       https://samba.org/~abartlet/
> Samba Team Member (since 2001) https://samba.org
> Samba Team Lead, Catalyst IT   https://catalyst.net.nz/services/samba
> Samba Development and Support, Catalyst IT - Expert Open Source
> Solutions

More information about the samba mailing list