[Samba] Group Policies are not applied

Pisch Tamás pischta at gmail.com
Tue Mar 16 14:53:18 UTC 2021


I set up a policy as test. When I run
gpupdate /force
on a Windows 10 client, I get error messages:
-Group policy processing was unsuccessful. Windows cannot resolve computer
-Group policy processing was unsuccessful. Windows cannot resolve user name.
The windows client was joined the domain, and I logged in with a domain
Server side: Samba 4.13.4. It is a fresh installation. I went through the
Samba documentation, and the test commands run successful, so I don't know,
what Windows cannot resolve.
I installed RSAT. I added our AD to the Group policy management tool. When
I click on ad.ourdomain.hu, I get an error:
Processing error encountered with this default domain controller while
data-collection (sorry, I tried to translate it from Hungarian to English).
Change the domain controller and try again.
I applied samba-tool sysvolreset after I got error message related to rpc
I installed two dcs: dc1, dc2. dc2 gets sysvol content with rsync.
        bind interfaces only = Yes
        dns forwarder =
        interfaces = lo eth0
        netbios name = DC1
        realm = AD.OURDOMAIN.HU
        server role = active directory domain controller
        workgroup = AD
        idmap_ldb:use rfc2307 = yes
        allow dns updates = secure only

        path = /var/lib/samba/sysvol
        read only = No

        path = /var/lib/samba/sysvol/ad.ourdomain.hu/scripts
        read only = No

Tamas Pisch.

More information about the samba mailing list