[Samba] Adding user to group doesn't propagate?

Harald Hannelius harald+samba at arcada.fi
Wed Jun 17 11:14:36 UTC 2020

On Wed, 17 Jun 2020, Harald Hannelius via samba wrote:
> On Wed, 17 Jun 2020, Rowland penny via samba wrote:
>> On 17/06/2020 11:54, Harald Hannelius wrote:
>>> On Wed, 17 Jun 2020, Rowland penny via samba wrote:
>>>> On 17/06/2020 11:39, Harald Hannelius via samba wrote:
>>> Sorry, You lost me here. Has this been discussed recently? I'm in the 
>>> middle of so many projects I haven't had time to sit and follow this list 
>>> as much as I'd like to.
>> No, it hasn't been discussed before, it happened to myself a couple of 
>> weeks ago, I added the user to a group and 'id' didn't show the group, 
>> everything else showed the user was a group member. I just put it down to 
>> one of those things, but the following day, 'id' showed the group, so I 
>> think it must be a cache problem.
> I see.
> I just checked, and all other users who show up correctly in the new group 
> are indeed not logged on to the domain.
> Could it be that an active session locks the group memberships until the user 
> logs out and in again? This might even be exactly like Windows works if I 
> read correctly.
>>> I read somewhere that there's some caching going on, but there was no real 
>>> solution on how to purge this cache other than have the client log out of 
>>> their computer and on again. I have asked my colleague to do this, so it 
>>> might be that waiting until tomorrow won't work.
>> I tried all that, it just worked the following day. The only thing I didn't 
>> do, raise the log level.
> Ok, I'll wait if the logout/login doesn't work.

The user restarted their computer and presto: 'groups username' showed the 
new membership on the member-server.

Nice to know this :)


Harald Hannelius | harald.hannelius/a\arcada.fi | +358 50 594 1020

More information about the samba mailing list