[Samba] drs showrepl failures

Wayne Merricks waynemerricks at thevoiceasia.com
Mon Feb 15 15:06:31 UTC 2016

Hi all,

I've been having DNS issues for about 3 months which is causing all 
sorts of weird problems (most things work fine but then we have days 
where random machines lose trust/can't login without un-joining and 
rejoining the domain).  The domain was working with no problems for 
nearly 5 months before this started happening.

I have Ubuntu 14.04 running Samba 4.1.6 using the internal Samba DNS.  
As a test (because I couldn't think of anything else to try), I also set 
up a temporary DC with a source build of the current stable samba 4.3.4.

If I run samba-tool drs showrepl under Samba 4.1.6 I get errors like this:
* In and Outbound Neighbors: "failed, result 121 (WERR_SEM_TIMEOUT)" or 
"failed, result 2 (WERR_BADFILE)
* KCC Connection Objects: Seems OK.

If I run it on Samba 4.3.4:
* Outbound neighbours and KCC seem OK, only Inbound has errors

Could anyone tell me where I should be looking to resolve this as I've 
exhausted Google of useful results.  My current plan is to update to 
Samba 4.3.4 however I'm curious why showrepl is failing before proceeding.



More information about the samba mailing list