[Samba] Samba 4.2.0rc1 build fails on Raspberry Pi

Peter Serbe peter at serbe.ch
Fri Oct 3 02:43:17 MDT 2014

Dear List, 

I tried to build samba-4.2.0rc1 on my Raspi. 
I did this:

./configure --prefix=/usr/local/samba \
            --with-piddir=/usr/local/samba/var/run \
            --with-syslog \
            --with-quotas \
            --with-acl-support \

Then after a couple of hours it crashes here:

# [3863/3973] Generating manpages/smb.conf.5
# Bus error
# Waf: Leaving directory `/usr/src/samba4/bin'
# Build failed:  -> task failed (err #135):
#         {task: manpages/smb.conf.5 smb.conf.5.xml,parameters.all.xml -> smb.conf.5}
# Makefile:8: recipe for target 'all' failed
# make: *** [all] Error 1

I don't see anything suspicious in the logs. With one exception: 

Oct  2 23:41:03 charon kernel: [103830.052440] smsc95xx 1-1.1:1.0 eth0: kevent 2 may have been dropped

The message occurs about 10 times. But I am not convinced that this is related to 
my problem to compile samba-4.2.0rc1. 

For the sake of completeness: I run Raspbian Jessie on the machine. 
A couple of apt-get updates earlier, compiling samba 4.1.11 and 12 
worked like a charm. A first web research revealed that typically 
bus errors, i.e. wrongly aligned data words, hint at some messy 
pointers. But the log is not verbose enough to give me any idea 
on how to attack this problem. 

Is this something, which needs to be solved by someone of the 
developers? What can I do??

Best regards

More information about the samba mailing list