[Samba] Samba error - Error: 0x80090345

Ken Bass kbass at kenbass.com
Fri Nov 28 12:09:01 MST 2014

On 11/28/2014 12:17 PM, Allen Chen wrote:
> I have a similar situation related to the "Domain Admins" group.
> If a user is in the "Domain Admins" group, then he couldn't start a 
> windows app.
> If I remove the user from "Domain Admins" group, also restart the 
> computer, then he can start the app.
> You can try this.
> I think it related the permission on the app over network path(UNC), 
> or something else like UAC.

I tried removing my user from the Domain Admins group (which is now 
empty). I rebooted and verified I could no longer do stuff like remote 
desktop so it does seem the change took effect. However, I still get the 
same error when trying to run the Credential Manager:
Error code: 0x80090345
Error Message: The requested operation cannot be completed. The computer 
must be trusted for delegation and the current user account must be 
configured to allow delegation.

What is really confusing me is that is the trusted for delegation stuff 
about? And how does it apply to NT style domains? And of course why does 
it work on other machines with the same user?

More information about the samba mailing list