[Samba] problems after lowering tombstone...

Achim Gottinger achim at ag-web.biz
Wed Jul 23 13:16:18 MDT 2014

Am 23.07.2014 21:00, schrieb mourik jan heupink - merit:
> Yep, /var/lib/samba should not be on btrfs. Disk space became less and 
> less, until the disk was full. Adding up various directory sizes came 
> nowhere close to the total diskspace. We added an extra btrfs 
> partition to increase available space, and it was also all used.
> We could temporarily decrease disk usage by
> 'btrfs filesystem defragment ./DC=DC=DOMAINDNSZONES,DC=SAMBA,DC=...ldb'
> but after a few minutes, it grew again.
> The sernet people have now located /var/lib/samba on an ext4 
> partition. We even encountered kernel errors and a server freeze when 
> trying to read/defragment the btrfs partition on another machine.
> So... no more btrfs in my shop.
> MJ
> On 7/23/2014 20:47, Achim Gottinger wrote:
>> Am 23.07.2014 19:16, schrieb mourik jan heupink - merit:
>>> Hi all,
>>> Just a heads up for all of you: I spend half a day on the phone with
>>> sernet, and the problem was most likely the fact that we were running
>>> our dc's on btrfs.
>>> So, a word of advise: don't use btrfs on your dc's. I was advised to
>>> use ext4, but I guess xfs should also do fine.
>>> Regards,
>>> Mourik Jan
>>>> How many "Deleted Objects" do you count at the two dc's maybe it's 
>>>> still
>>>> in the process of purging old ones.
>> So was the database corrupted on your dc's 1 and 2 due to btrfs errors?
>> Odd that you get NT_STATUS_RPC_PROTOCOL_ERROR because of fs issues.
>> Thanks for the report.
>> achim~
You know the odd thing is i just decreased tomstone lifetime from 180 
down to 30 days on an setup with windbind issues in hope to get some 
speed improvements.

The samba process is still busy ~90% and if i run samba-toor drs 
showrepl i get the same error while still having 5GB free on /var.

I assume your db corruption was caused by no space on /var (due to brtfs 


ERROR(runtime): DsReplicaGetInfo of type 0 failed - (-1073610723, 
   File "/usr/lib/python2.7/dist-packages/samba/netcmd/drs.py", line 
116, in drsuapi_ReplicaInfo
     (info_type, info) = 
ctx.drsuapi.DsReplicaGetInfo(ctx.drsuapi_handle, 1, req1)

More information about the samba mailing list