[Samba] directory checksum error during tar extract

Steve Thompson steve at etcia.com
Wed Feb 26 11:01:37 MST 2014


          I now have an unpacked copy of the tarball in a directory and need
to compile it, but am having no luck at getting the instructions under
"Building Binaries" from the Samba site to work.
Specifically what is the "autoconf tool kit" since there is no "configure
script in the source4 directory that I have.

          I tried "./autogen.sh" in that directory, but it did nothing and
gave no errors.

          Thank you for your help!

-----Original Message-----
From: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org]
On Behalf Of Thomas Schulz
Sent: Tuesday, February 25, 2014 8:24 PM
To: samba at lists.samba.org; steve at etcia.com
Subject: Re: [Samba] directory checksum error during tar extract

> Hello,
>           On a Sun Solaris system running Solaris 2.6 to upgrade from 
> Samba  2.0.6:
>           I am trying to 'tar xnvf Samba-4.1.5.tar' (un zipped from 
> Samba file version 4.1.5) downloaded yesterday.  I keep getting  a 
> "tar: directory checksum error" when I reach the line "x 
> samba-4.1.5/codepages/lowcase.dat,
> 131072 bytes, 128k".
>           Please help!  Thank you.
> Steve Thompson, Information Systems Manager
> Electronic Tele-Communications, Inc.
> (770) 921-7466   email: steve at etcia.com

The Solaris tar will not work. The GNU tar will work. I ran into this on
quite a lot of different software packages, not just Samba. Solaris 10 comes
with a version of gtar. I don't know just when they started to include it,
but it is not on Solaris 8. Long ago I downloaded the source for GNU tar and
built it, probably back when we were running Solaris 2.5.1.

All that said, I have sucessfully built a working Samba 4.1.5 on Solaris 10
but have not yet gotten it to work on Solaris 8. The build runs to
completion but the result does not work. There are quite a lot of functions
that Solaris 8 does not have and I expect that I will eventually find out
which one is needed.

We are currently sucessfully running Samba 3.6.22 on Solaris 8. I never
tried any of the Samba 4.0.* versions. You will need gtar to untar Samba
3.6.22 also.

Tom Schulz
Applied Dynamics Intl.
schulz at adi.com
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list