[Samba] Samba 4 "Services for UNIX"?

Robert Moggach rob at dashing.tv
Tue Jan 8 16:43:56 MST 2013

I've solved getting the schema into the directory... and I thought I
populated my automount maps...
but the directory is unbrowseable -

Getting closer... I keep getting the following error:

*acl_read: cannot get descriptor of automountMap... etc. etc.*

Steps I took...
1) I had changed the Default-First-Site-Name to something more appropriate
and changing that back seemed like a good place to start even though fsmo
was showing me as the SchemaMaster -

2) At this point I was able to get the schema loaded... almost... ldapadd
didn't like attributes and class in the same ldif... and then I had to
restart samba to add the class file... ugh... use ldbmodify! I edited the
automount.ldif schema file to be two files - one for the attributes and a
second for the classes

I added the schema using the following two commands:

ldbmodify -H /usr/local/samba/private/sam.ldb
/root/SAMBA4/automount/autofs_attr.ldif --option="dsdb:schema update

ldbmodify -H /usr/local/samba/private/sam.ldb
/root/SAMBA4/automount/autofs_class.ldif --option="dsdb:schema update

4) I then tried to add the automount records with ldbmodify with no luck ...
ldbmodify -H /usr/local/samba/private/sam.ldb
Sorting rpmd with attid exception 3 rDN=CN
ERR: (Naming violation) "objectclass: Invalid RDN 'AUTOMOUNTMAPNAME' for
objectclass 'automountMap'!" on DN
automountMapName=auto_master,CN=mac,CN=autofs,CN=Services,DC=MYDOMAIN at
block before line 41
Modify failed after processing 5 records

Weird... solved that by doing the following, but now i have all kinds of
acl_read errors

ldbmodify -H /usr/local/samba/private/sam.ldb.d/DC\=MYDOMAIN.ldb

ldapsearch gives me the following:

result: 1 Operations errorsearch: 5
result: 1 Operations error
text: acl_read: cannot get descriptor of automountMapName=...

weird? how do I add acls?

The following shows the whole directory as expected... but I need ldap to
work for autofs!

ldbsearch -H /usr/local/samba/private/sam.ldb

So can someone tell me how to get acls added for my objects?

Samba version: 4.1.0pre1-GIT-94f11e9
Build environment:
   Build host:  Linux crawford 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19
07:05:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

More information about the samba mailing list