[Samba] Linux/Winbind AD domain member loses membership after about 4 days

Kristofer kristofer at cybernetik.net
Thu Nov 15 22:32:50 MST 2012

I believe there is an issue with winbind.  I saw the same thing, and scheduled a winbind restart every 6 hours (probably don't need to do it that often, but I wanted to be safer than sorry).

On Nov 13, 2012, at 4:19 PM, Andrew Galdes wrote:

> Hi all,
> I have a Linux server running Samba (samba-*-3.5.10-115) and Winbind on
> CentOS 6.2. I've joined it to the domain using "net rpc join..." and it
> worked fine. "wbinfo -u" lists users as i'd expect. However, after a few
> days, the Linux server loses it's ability to see users on the domain. I
> restart all related services "smb, nmb, winbind" but still no joy. I
> re-join the server to the AD with "net rpc join..." again and it works
> again. The time is correct on the DC and the Linux server.
> The join was first done on Thursday last week at about 3:pm. It remained
> working until about 3:pm yesterday. 4 days to the hour (about).
> There are errors which i can't list here right now. They essentially say
> "authentication failed" and "NT_..._ACCESS_DENIED".
> I did try using "authconfig" to join the domain but it failed. Hence the
> "net rpc join..." command.
> Any thoughts?
> -- 
> -Andrew Galdes
> Managing Director
> AGIX Linux
> Ph: 08 7324 4429
> Mb: 0422 927 598
> Site: http://www.agix.com.au
> Twitter: http://twitter.com/agixlinux
> LinkedIn: http://au.linkedin.com/in/andrewgaldes
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list