[Samba] compiling samba 3.4.8 on CentOS_6.2

Nico Kadel-Garcia nkadel at gmail.com
Tue Jul 10 19:06:39 MDT 2012

On Tue, Jul 10, 2012 at 7:32 PM, Randy Rue <randyrue at gmail.com> wrote:
> Hello All.
> Been trying without avail to make idmap work with my AD so I can get "real"
> UID/GID for SSH logins on a CentOS_6 box. Have heard from several sources
> that idmap has seen some serious changes since 3.5 and decided to roll back
> from the "stock" 3.5 that comes with CentOS_6 to 3.4.8. I'd like to see if
> it has the same problems.

Save yourself some grief. Either go to www.samba.org for a more recent
version, or look at:

https://github.com/nkadel/samba-3.6.4-srpm for some useful and very
buildable tools for a more recent release.

> Installed a clean build of CentOS_6.2. Stopped the samba service, removed
> the package using yum and excluded samba* from yum updates in /etc/yum.conf.
> Downloaded and extracted the 3.4.8 tarball.
> cd into samba-3.../source3 and ran:
> the autoconfig.sh script
> ./configure
> make
> make install
> copied the smb.init script from the packaging/RHEL/setup folder to
> /etc/init.d and made it executable
> chkconfig --add smb
> chkconfig smb on
> service smb start fails. Tries to start both smbd and nmbd and both fail.
> First I get errors about libraries.
> copied the libtalloc.so.1 file from /usr/local/samba/lib to /usr/lib64
> fixed that one
> Then I get errors about not finding the binaries
> linked /usr/local/samba/sbin/smbd and nmbd to /sbin and fixed that one
> This feels like a hack. I also tried adding /usr/local/samba/sbin to the
> path. Also a hack but made no difference.
> Now if I try service smb start (or restart) I get failures from the init
> script.
> Or I can try smbd directly and I get no response (it appears to start) but
> "ps" shows that it didn't start.
> I've turned debug level and log level up to 3 in smb.conf (tried both
> arguments) but I get nothing in /var/log/syslog and nothing in any file in
> /var/log/samba when I try to start it.
> Forgive the anecdotal tone of the above, I'm working mostly from memory and
> have probably garbled a path or file name. Then again, I've been through
> these steps six or more times now.
> Am I missing something obvious?
> Hope to hear from you,
> Randy
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list