[Samba] SMB2 weird behavior with samba 3.6 PDC

Mark Reidenbach mark.a.reidenbach at gmail.com
Mon Aug 15 20:53:18 MDT 2011

On Mon, Aug 15, 2011 at 5:28 PM, Linda Walsh <samba at tlinx.org> wrote:

> ` Mark Reidenbach wrote:
>> I tried enabling SMB2 on our network after upgrading to samba 3.6 and
>> experienced the following problems.  Commenting out "Max Protocol = SMB2"
>> makes the windows7 and vista clients happy.
>>   - [homes] Trying to open a html file in notepad fails on Windows7 Pro
>>   SP1.  Opening it in Firefox (default browser) or Open Office works ok.
>>   - [homes] Mozilla Thunderbird insists on downloading all the IMAP
>> headers
>>   each time it is launched on Vista Pro SP2.
>       What is it supposed to do?   My client checks for new headers and
> downloads them all on each launch.  Of course what's really fun is when
> you get to TB3 or above and it copies all of your IMAP folders into your
> local roaming profile by default (and it isn't easy to disable unless
> you already know how to do it).
>       Great design...down load all IMAP messages from local server, and
> then entire mail store gets sent back up to the server in logon (as
> profile is stored)... and must be synced on login...  The Tbird people,
> apparently didn't (and still refuse to understand  that IMAP is a remote
> file-system that's not designed to have all of it downloaded to each
> client you login to.  Whereas pop, usually when you d/led it, it was off
> the server (though that later changed -- but it still doesn't keep
> status the way IMAP does, nor does it have the search functions of IMAP.
> You can have IMAP create a searchable DB of your email so larger
> searches are lightning fast...instead, they copied my entire 4.5G mail
> folder onto each local machine and account i used mozilla on.

What I meant to say is that Thunderbird downloads every message every time
it is launched when I have "max protocol = smb2" enabled.  Without that line
it checks the headers and is done.  Even if it's not efficient I don't mind
it downloading and caching the message once, but having to do so on every
launch takes a lot of time and a lot of bandwidth.

>  computer or a USB key to samba
>>   works ok, but Firefox and Chrome are unable to save files to the samba
>>   shares.  They download files ok (e.g. file.part) but seem to be unable
>> to
>>   rename the file when the download is complete.
> ---
>       Yeah that was another problem I tried reporting and to get info on
> over a month ago, but never  got a response.  Part of my problem (maybe
> all of it), is they changed the idmap backend -- I was using static
> UID/GID mappins for the most part,   when I went to 3.6, all of my GID's
> changed and my pwdb got very hosed.   Still haven't recovered (most
> things work, but winbind refuses to return any info on my GUID, even
> though locally it knows what UID it maps to.  But log is filled with
> GUID lookup errors for mine and random ones -- alot of "S-0-0".
>   The problem on the 'that'file is that apparently smb2 opens the
> file you want to save in, first, but doesn't close it -- then downloads
> to a .tmp file, and then does a rename over the first (or a copy, not sure
> which).
>   Anyway server refuses to allow it -- as it thinks the first
> file is still open.
>   If you have server 'recycle bin' turned on (the samba module), (and
> use savetree), you'll find the completed files in your recycle bin
> named with some pnnnn.xxx tmp name.   Just rename the file from the server
> and copy it over the first.
> I don't have a windows server to test against, but surely this isn't
acceptable behavior from a windows server.  Hopefully one of the samba team
members could help debug why all common browsers are unable to download
files to a samba share.

>    - [public] Installing programs from samba seems to partially work.
>>   Installing Itunes 10.4 for 64 bit windows 7 seemed to work but the Apple
>>   Software Update program was not installed (uninstalling, copying
>>   iTunes64Setup.exe to the desktop, and running the setup program worked).
> ----
> Odd, I've had a similar prob w/nvidia's sw-update prog -- but I wouldn't
> have though it to be samba related...
> Good luck --- I'm back at 3.10 -- and still have figured out how to
> repair my DB.
> Apparently the DB format got changed, and isn't backward compat (or
> something!) -- i.e. when looking up my domain, it tries to look for '*'
> first, which it then expecs to hve return the domain.   I have no '*'
> entry in my tdb file.  Top level entry that everything is under is the
> Domain name.
> So many types of lookups don't work.
> Had lots of performance problems with MSWin swamping my network
> connection really bad -- so that I couldn't play AV hosted on the
> server.  Tried every downward tuning option available (my net was
> optimized for SMB1 -- 125MB writes/ 119-121MB/s reads over a 1Gbit
> net...(max speed, not average!)  But I think that the new SMB2 code is
> much 'tighter in windows, so it executes more quickly so it is difficult
> for other traffic to get a chance.
> Unfortunately MS designed their file-serving protocol to be
> undifferentiable for setting QOS on...(i.e. it establishs 1 connection
> in the name of 'system', and all I/O to/from server goes through the 1
> server.  So no way for a user to prioritize I/O (can prioritize by port,
> but as all file  i/o is done through 1 port, doesn't help, and by process,
> except that system does the I/o for file processes -- all glummed together.
> It's just peachy!
The file copy speeds on our local gigabit network seem to be about the same
as with SMB1.  Our main desire for SMB2 is for our vpn connections where
browsing speed is greatly increased.  I also haven't noticed any passdb
problems between samba 3.5.8 and 3.6.0 other than dealing with Windows 7 UAC
where it seems the domain user's primary group must be Domain Administrators
to get past the popup (simply being in the Domain Administrators group does
not seem to work).

More information about the samba mailing list