Tiago Damasceno ::: TDA INFORMÁTICA tiago at tdaconsultoriadigital.com.br
Sat Jun 19 06:34:40 MDT 2010

This facility was not made by me but by another trader who worked here in
the company before me.
He did not follow the standard methods of directory applications, so you
must be wondering the files in different directory.

I'm having a hard time understanding what my predecessor did, since it was

Actually I thought about reinstalling the samba and make a new file server,
however, my United Linux distribution is based on a very old version of
SUSE, when I try to upgrade samba to a newer version it asks a series of

I'm afraid that installing these dependencies can cause some side effects,
because I have an application running on the Oracle server.

Did not anyone could just send me this file? Since we can not find anywhere
the blessed?

2010/6/19 Michael Wood <esiotrot at gmail.com>

> 2010/6/19 Tiago Damasceno ::: TDA INFORMÁTICA
> <tiago at tdaconsultoriadigital.com.br>:
> > I found the rpm file regarding my samba version, but it did not come to
> the
> > smbd file in which I need:
> You have found the source version of the file and not the binary
> version.  The one you want should be called something like
> samba-2.2.5-107.i586.rpm (or maybe i386 or x86_64 or something other
> than src.)
> Either you should find the binary package, or you will need to compile
> the source package.  If you can find the correct binary package that
> would be easiest.
> > Under the procedures that I did with him:
> > 1. Under the guidance of Pablo Chamorro extract the file with the
> command:
> > rpm2cpio samba-2.2.5-107.src.rpm | cpio-IDMV he extracted the files all
> > right, but the file which I need smbd is not contained in the package.
> >
> > Following is the list of extracted files:
> > drwxr-xr-x 3 root root 4096 Jun 19 08:49.
> > drwxrwxrwx 6 oracle dba 12 288 Jun 16 17:39 ..
> > -Rw-r - r - 1 root root 2813 Sep 23 2002 README.SuSE
> [...]
> By the way, what strange e-mail client are you using that randomly
> capitalises things like the "r" in -rw-r--r-- and also randomly
> removes some of the dashes?
> > 2. Updated with the command rpm-U samba-2.2.5-107.src.rpm, trying to be
> > compressed it into another file, also failed, still showing the message
> > below when I start the smb service.
> > Samba daemon, / usr / lib / samba / classic / smbd is not installed
> /usr/lib/samba/classic is a strange location for Samba.  What
> distribution is this anyway?
> > 3. I did backup the current settings of the samba and tried to do a fresh
> > install over the existing (rpm-i samba-2.2.5-107.src.rpm), it executes
> the
> > command correctly, but I still returns the message error so when I try to
> > start the service.
> Since this is the source package, "installing" it would just unpack
> the source code to somewhere like /usr/src/...
> P.S.  Version 2.2.5 is very old.  It might be better to set up a new
> server with a new version of Samba (e.g. 3.4.x or 3.5.x) and then move
> the other services over to that too.
> --
> Michael Wood <esiotrot at gmail.com>


Tiago Damasceno
E-mail: tiago at tdainformatica.com.br
Telefone: +55 86 3315 2819 / 9451 9892
skype: tiagodamasceno6
MSN: tiago at tdaconsultoriadigital.com.br

More information about the samba mailing list