[Samba] Printer Driver Delivery - Printing Preferences Error

Hoover, Tony hoover at sal.ksu.edu
Wed Dec 1 14:25:27 MST 2010

The Xerox Work Centre print drivers do a LOT of server registry stuff
(during the print process).  I could never get them to function reliably on
a samba server.  However, using either the "HP universal drivers" for PCL
output or the CUPS driver for Postscript output, I was able to make the
Xerox print reliably. 

The coin-mech attached to the printer, however, could not be configured to
meet the requirements set by the department, so we no longer have a Xerox
Work Centre on campus.

Tony Hoover, Network Administrator
KSU - Salina, College of Technology and Aviation
(785) 826-2660

"Don't Blend in..."
-----Original Message-----
From: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org]
On Behalf Of Beau Sapach
Sent: Wednesday, December 01, 2010 2:40 PM
To: samba at lists.samba.org
Subject: [Samba] Printer Driver Delivery - Printing Preferences Error

Hello everyone,

I've got a Xerox Work Centre 5735 that I'm printing to via Samba.  When I
install the drivers on a client (using the right-click-Connect method) from
the samba shared printer then the install goes smoothly but I can't load the
Printing Preferences dialogue for that printer, I get an "Operation could
not be completed" error.  This same error does not occur when I install the
same printer on the same workstation - but this time from a Windows 2003
server instead of the Samba server.  Even when I have both the samba and
Windows Server 2003 printers side-by-side this problem exists for one but
not the other.

Upon further investigation I see that there are sub keys of:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan
Print Services\w2k3server\Printers\XeroxWorkCentre5735PS

Namely: PnPData, PrinterDriverData, PrintProcCacheData,

And these keys don't exist under the equivalent
\sambaserver\Printers\XeroxWorkCentre5735PS key.

I've tried merging the missing keys (and missing values from DsSpooler &
PrinterDriverData) from one to the other but the extra keys are blown away
as soon as I do anything with the samba server's printer.

Since the Xerox Printing Preferences dialogue looks pretty custom, I suspect
that there are classes, controls etc. that are registered by a Windows ->
Windows driver delivery that don't get done with a Samba -> Windows
delivery.  If anyone has any advice, a work around etc. any help would be
much appreciated.  Thanks!


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list