[Samba] Printer Driver Delivery - Printing Preferences Error

Beau Sapach beau.sapach at concordia.ab.ca
Wed Dec 1 13:40:03 MST 2010

Hello everyone,

I've got a Xerox Work Centre 5735 that I'm printing to via Samba.  When I install the drivers on a client (using the right-click-Connect method) from the samba shared printer then the install goes smoothly but I can't load the Printing Preferences dialogue for that printer, I get an "Operation could not be completed" error.  This same error does not occur when I install the same printer on the same workstation - but this time from a Windows 2003 server instead of the Samba server.  Even when I have both the samba and Windows Server 2003 printers side-by-side this problem exists for one but not the other.

Upon further investigation I see that there are sub keys of:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\w2k3server\Printers\XeroxWorkCentre5735PS

Namely: PnPData, PrinterDriverData, PrintProcCacheData,

And these keys don't exist under the equivalent \sambaserver\Printers\XeroxWorkCentre5735PS key.

I've tried merging the missing keys (and missing values from DsSpooler & PrinterDriverData) from one to the other but the extra keys are blown away as soon as I do anything with the samba server's printer.

Since the Xerox Printing Preferences dialogue looks pretty custom, I suspect that there are classes, controls etc. that are registered by a Windows -> Windows driver delivery that don't get done with a Samba -> Windows delivery.  If anyone has any advice, a work around etc. any help would be much appreciated.  Thanks!


More information about the samba mailing list