[Samba] Windows 7 RC

SkyBeam rme at bluemail.ch
Wed Sep 2 01:28:01 MDT 2009

kmorning wrote:
> I installed windows 7 RC and was able to join my samba 3.3.6 domain and
> just as with server 2008r2 I ran into the "trust relationship" issue when
> trying to log into the domain.  At this point I became a little frustrated
> since it seems everyone else here has had success with this.
> Finally, as a last ditch effort, I decided to downgrade to 3.3.4 since
> I've seen no mention of anyone using 3.3.6 in this scenario.  Lo and
> behold, my domain logins now work in both win7 and win2008r2. 
> Now this would lead me to believe something in 3.3.6 has broken this
> functionality, but I don't want to say this with absolute certainty. 
> Perhaps in my process of uninstalling 3.3.6 and installing 3.3.4 I fixed
> something unbeknownst to me.
> I'm using a gentoo distro, and the reason for me initially installing
> 3.3.6 was because it was the the only ebuild for a 3.3.x flavour in the
> portage tree (which I had to unmask since it is still hard masked).  After
> unemerging 3.3.6 I created a portage overlay for 3.3.4 and emerged it.
> Can someone confirm (or deny) my findings with 3.3.6?

I can confirm this findings.

I am running Gentoo Linux and my Samba was on latest 3.0 release. Changing
the registry keys in LanmanWorkstation parameters to enable domain
compatibility helped to join the domain. However the error about changing
the primary DNS domain remained.
I don't know if this is relevant at all or just annoying. The DNS suffix for
the connection is published by the DHCP server here. But maybe the message
is about something else.

Anyway I immediately faced the problem that the trust relationship between
the workstation and the machine failed when I try to log in: "The trust
relationship between this workstation and the primary domain failed."

So I followed this thread and first upgraded to the latest Samba release
available for my distribution (Gentoo) which was 3.3.6. Still no go.
Following your suggestion I've created a local overlay and some Samba 3.3.4
overlays. Surprisingly you're right and Samba 3.3.4 works great. So
something has been broken (or enhanced in a Win-7 incompatible way) in Samba
If I find some time I will try to use Samba 3.4 too but this might be more
difficult than my 3.3.4 overlays...

(Running Windows 7 Professional RTM, no Beta/RC)
View this message in context: http://www.nabble.com/Windows-7-RC-tp23405949p24982658.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list