[Samba] Missing files and folders on Vista

Antoine Leblanc crucuny at gmail.com
Thu Sep 4 16:48:47 GMT 2008

Antoine Leblanc a écrit :
> Antoine Leblanc a écrit :
>> Hello everyone.
>> I'm having a small problem while using samba 3.0.30 on FreeBSD that 
>> two months of googling haven't managed to fix: when a folder contains 
>> two many elements, Vista only lists a small amount of them. I made my 
>> tests with a folder containing around 1000 sub-folders (which have the 
>> same unix file mode). Vista was first only showing around 250 of them. 
>> After upgrading samba to 3.0.30, Vista "sees" around 400... When 
>> connecting from Mac OS X I can see the whole 1000 sub-folders. Has 
>> anyone already met this kind of problem?
>> Thanks for reading (and sorry for my poor English).
> Some news from that:
>   - the missing folders contain no accent or any specific character that 
> may cause any problem,
>   - if I move any of the missing folders into any other less "crowded" 
> folder, I can see it and access it without any problem,
>   - if I enter the name of the missing folder in the address bar, I can 
> also access it without any problem.
>   - XP sees exactly the same amount of folders that Vista does,
>   - by just creating a new directory (`mkdir test`) in the folder, the 
> number of folders seen jumped from 411 to 548.
> Thanks in advance for your help!

I might even add (sorry for spamming) that the number of folders seen 
highly depends on actions such as creating a new sub-folder :
   - as mentioned, creating a "test" folder increases the number of 
folders seen to 548 ; deleting it brings back the counter to 411,
   - creating a new folder "test" with Vista brings down the counter to 135,
   - if I move all the folders in a new sub-folder, Vista now sees n - 1 
of them. Moving them back brings the number of folders seen to what it was.

That seems to be highly irrational... I tried to set a high debug level, 
but accessing and refreshing the folder does not seem to trigger any 
log. I also tried to deinstall and reinstall samba then reboot the 
server, but that didn't change anything.

Thanks in advance for any help!

Antoine Leblanc

More information about the samba mailing list