[Samba] net rpc shutdown does not work

thuan tran thuanbkit at gmail.com
Mon Jul 7 14:11:56 GMT 2008

I seems to find out the problem by running the command "net rpc user info
root" on my ubuntu box it returns
*Domain Users
Domain Admins

on my centos 5.2 box it only returns
*Domain Users

I have checked the ldap tree on the centos box, user root is indeed in group
512 or "Domain Admins". Trying smbldap-usermod -G +512 root also says so.

Using the command "net rap groupmember add 512 root" doesn't do anything. Or
is it "net rap groupmember add "Domain Admins" root"? I tried both as I
don't know for sure which is right and still no *Domain Admins *when calling
"net rpc user info root".

Creating a new user and add him to group 512 also yield the same result, no
*Domain Admins *when calling "net rpc user info root".

Any idea on what I did wrong or is it a well known problem as when I search
for this *"net rpc shutdown" WERR_ACCESS_DENIED* on google it returns quite
a few hits?

I did find a workaround but it's far from elegant as I have to change "Force
shutdown from a remote system" policy on every client machine. Please some
expert shed some light on this. I'm new to Linux and even more new to Samba
and LDAP. I'm desperated for knowledge on this problem.

Thuan Tran

P.S.: I changed my email address.

More information about the samba mailing list