[Samba] Re: Group membership not meshing

Chad masterclc at gmail.com
Tue Dec 30 21:33:46 GMT 2008

On Tue, Dec 30, 2008 at 11:13 AM, Chad <masterclc at gmail.com> wrote:
> Hello,
> I have a user who shows up as a member of the office_administration
> group when I run:
> getent group | grep office_administration
> However when I login as the user and run:
> groups
> or
> id
> I don't see the office_administration group listed.  And when the user
> tries to write to a directory that the office_administration group
> owns and has permission to write to, she is denied access (which I'm
> assuming is because the group problem noted above).
> Any ideas on how I can remedy the problem?  Any information I can
> provide I'll be happy to do so, just let me know what you need.
> Thanks!
> Gentoo Linux 2.6.24
> Samba 3.0.32
> -Chad

Just to follow up:

I had to user log out.  I then logged in as the user, and ran:
newgrp office_administration

Checked and verified and now when I run "groups" it shows up in the
list.  The user logged back into her XP machine and can now write to
the share.

Any ideas on why this would happen, and how to avoid having to
manually log in as the user and run newgrp in the future?



More information about the samba mailing list