[Samba] connection to IPC$ denied due to security descriptor

richid rich.schu at gmail.com
Wed Nov 21 15:37:32 GMT 2007

Hey all,

I have a fileserver running Debian Etch and Samba 3.0.24 that I use to serve
media and private home directories.  I have a couple roommates, and
therefore have a couple accounts on the box for those users.  I had
everything working perfectly until last week when my system drive took a
crap.  I've reinstalled everything exactly the same (I think?) but now I am
having problems with some accounts not being able to connect to the shares. 
My username can connect to my home share and the communal media share just
fine.  When I try to connect to another users home share or to the media
share with their username, I keep getting the password dialog box.  I've
ensured that they are in smbpasswd and that their password is correct.  I've
also verified this using smbclient.  


The log file is reporting this error when I try to connect:
    make_connection: connection to IPC$ denied due to security descriptor.

Here is output from smbclient:
    bob at warehouse:~$ smbclient //warehouse/media -U bob
    Domain=[WAREHOUSE] OS=[Unix] Server=[Samba 3.0.24]
    smb: \> ls
      .                                   D        0  Thu Oct 18 11:25:22
      ..                                  D        0  Wed Nov  7 21:47:06
      audio                               D        0  Tue Nov 13 23:40:25
      downloads                           D        0  Tue Nov 13 23:41:11
      video                               D        0  Thu Nov 15 23:00:34

                    44708 blocks of size 33553920. 25310 blocks available
    smb: \> 

Here is my smb.conf:

   netbios name = warehouse
   server string = warehouse
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   invalid users = root
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n 
   socket options = TCP_NODELAY
   domain master = auto

force user = %U
force group = users

   comment = Home Directories
   browseable = no
   writable = yes
   create mask = 0700
   directory mask = 0700
   force group = %G
   valid users = %S

   comment = Media
   path = /mnt/storage/media
   browsable = yes
   writeable = yes
   create mask = 0775
   directory mask = 0775
   #guest ok = yes
   hide files = /*.dat/

It's pretty basic, I'm not doing anything special here.  Anyone have any
idea what the problem is?  I've also read a couple other threads, and have
already tried removing the /var/run/samba/share_info.tdb file and restarting
Samba, but that hasn't worked.  I'm really stumped on this one, anyone else?

Thanks in advance,
View this message in context: http://www.nabble.com/connection-to-IPC%24-denied-due-to-security-descriptor-tf4828629.html#a13814810
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list