[Samba] windows clients can't see workgroup at all

Derek Podoll derek at podoll.com
Wed Mar 28 20:59:04 GMT 2007

Here are a few things you might try if the samba server is the only server
on the network.  In the smb.conf file make sure
wins support = yes
And on the windows computer in the tcp/ip settings add the ip address of
the server to the wins tab.  Then when the servers and other windows
computers are running check the logs on the server to see if one of the
windows computers is fighting with the Samba server for browse master on
the network.  If this is happening change the OS level in the smb.conf
file to make samba win the master browser slot on the network.

If this samba server is not going to be the wins server
add these settings to the smb.conf
wins support = no
wins server = ( ip address of your wins server)
Make sure the wins server ip address is set in the tcp/ip settings

> I'm trying to troubleshoot a new samba setup on a tiny network, and I'm
> clearly missing something. I'm running Samba 3.0.22 on Ubuntu Linux.
> When I first set it up, it seemed to go so smoothly. I changed all the
> workstations to the same workgroup (RABNETWORK) and they could see each
> other and the server, but they couldn't open anything on the server. I
> don't
> really understand what the problem is, but I didn't change anything, I
> gave
> up and went home. Now, none of the workstations can browse the network at
> all. When I click "View workgroup computers" the error I get says that the
> network is not accessible. Even with the server off, the network is not
> accessible (hence my suspicion that samba is not the problem).
> What I can't sort out is what the problem is likely to be. I tried
> stopping
> the firewall (AVG) altogether, which didn't make a difference. I tried to
> walk through this diagnosis worksheet:
> http://samba.org/samba/docs/man/Samba-HOWTO-Collection/diagnosis.html
> and got the following results:
> 1) testparm works
> 2) ping by name fails; I can ping the server's IP address from the Windows
> clients, but can't ping the Windows machines from the server.
> 3)  works: smbclient -L BIGSERVER
> Domain=[BEASTIE] OS=[Unix] Server=[Samba 3.0.22]
>         Sharename       Type      Comment
>         ---------       ----      -------
>         homes           Disk      Home Directories
>         print$          Disk      Printer Drivers
>         Share Drive     Disk      This is the server.
>         tmp             Disk      temporary files
>         IPC$            IPC       IPC Service (beastie server (Samba,
> Ubuntu))
>         ADMIN$          IPC       IPC Service (beastie server (Samba,
> Ubuntu))
>         amanda          Disk      Home Directories
> Domain=[BEASTIE] OS=[Unix] Server=[Samba 3.0.22]
>         Server               Comment
>         ---------            -------
>         Workgroup            Master
>         ---------            -------
>         RABNETWORK           BEASTIE
> 4) works: *nmblookup -B BIGSERVER __SAMBA__
>           amanda at beastie:~$ nmblookup -B BEASTIE __SAMBA__
>           querying __SAMBA__ on
>  __SAMBA__<00>
> *5) fails:* nmblookup -B ACLIENT '*'**
>            amanda at beastie:~$ nmblookup -B presta '*'
>            querying * on
>   *<00>
> I'm stopping here because it seems pretty clear that the Windows XP client
> machines are hating me.Where do I go from here?
> Thanks,
> Amanda
> *
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list