[Samba] windows clients can't see workgroup at all

Amanda Bee moraving at gmail.com
Wed Mar 28 22:44:53 GMT 2007

I'm trying to troubleshoot a new samba setup on a tiny network, and I'm
clearly missing something. I'm running Samba 3.0.22 on Ubuntu Linux.

When I first set it up, it seemed to go so smoothly. I changed all the
workstations to the same workgroup (RABNETWORK) and they could see each
other and the server, but they couldn't open anything on the server. I don't
really understand what the problem is, but I didn't change anything, I gave
up and went home. Now, none of the workstations can browse the network at
all. When I click "View workgroup computers" the error I get says that the
network is not accessible. Even with the server off, the network is not
accessible (hence my suspicion that samba is not the problem).

What I can't sort out is what the problem is likely to be. I tried stopping
the firewall (AVG) altogether, which didn't make a difference. I tried to
walk through this diagnosis worksheet:

and got the following results:
1) testparm works
2) ping by name fails; I can ping the server's IP address from the Windows
clients, but can't ping the Windows machines from the server.
3)  works: smbclient -L BIGSERVER

Domain=[BEASTIE] OS=[Unix] Server=[Samba 3.0.22]

        Sharename       Type      Comment
        ---------       ----      -------
        homes           Disk      Home Directories
        print$          Disk      Printer Drivers
        Share Drive     Disk      This is the server.
        tmp             Disk      temporary files
        IPC$            IPC       IPC Service (beastie server (Samba,
        ADMIN$          IPC       IPC Service (beastie server (Samba,
        amanda          Disk      Home Directories
Domain=[BEASTIE] OS=[Unix] Server=[Samba 3.0.22]

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
        RABNETWORK           BEASTIE

4) works: *nmblookup -B BIGSERVER __SAMBA__
          amanda at beastie:~$ nmblookup -B BEASTIE __SAMBA__
          querying __SAMBA__ on

*5) fails:* nmblookup -B ACLIENT '*'**
           amanda at beastie:~$ nmblookup -B presta '*'
           querying * on

I'm stopping here because it seems pretty clear that the Windows XP client
machines are hating me.Where do I go from here?



More information about the samba mailing list