[Samba] Problems sharing HP Officejet 6210 Linux --> XP

1arrybarnett lb99999999 at aol.com
Tue Apr 10 22:32:30 GMT 2007

[cross-posted from www.tek-tips.com]

Dear samba forum,

I've now wasted most of a weekend on this issue, so now it's time to swallow
my pride and ask for help!


My main home computer died. I can't afford to replace it right now, so I'm
attempting to retread an old AMD PC into a linux print/file server. Clients
are a mixed bag of Windows XP home/professional PCs. The printer is an HP
Officejet 6210 multifunction print/scan/fax. I'm only attempting to get
basic printing working between Windows/Linux.

File shares to the PCs are working great. The printer is working locally via
cups and hplip. The printer is exported via Samba and is visible from the
windows boxes (i.e., you can see it in Network Neighborhood and get the
status of the print queue using the DOS 'net print' command). You can see my
smb.conf file at the bottom of this post.


The basic catch-22 with this printer model is that the drivers aren't part
of the standard XP distro. The XP printer installation wizard expects the
drivers to be available from the print server. After searching the net, I
came across this basic installation method:

1. Temporarily plug the printer into the XP PC and install the drivers from
the Printer CD. Then plug the printer back into the linux server.

At this point 2 techniques were suggested, neither of which worked for me:

2a. Go back to the wizard and install the remote printer, using the correct
driver this time. This apparantly succeeds, but printint the test page fails
with an uninformative popup inviting me to go to the troubleshooting wizard
(which is equally unhelpful).


2b. Hack the local printer configuration by going to properties-->ports and
creating a Local port with the value \\<servername>\<printername>, as shared
by Samba. This step fails for me with error 66 "The network resource type is
not correct".

So that's it, I'm stuck. I would love to hear from anyone who has worked
through this problem already. Failing that, how can I pick apart this
problem to figure out what's failing?

Note: There was also some discussion in the forums about the print$ share
and loading drivers on the Linux box, but I never figured out if that was
relevant to my use case (Linux server/Windows client).

Many thanks in advance to those who reply.



My smb.conf

# Samba config file created using SWAT
# from (
# Date: 2007/04/08 18:33:12

        workgroup = HOMENET
        server string = Samba Server
        log file = /var/log/samba/%m.log
        max log size = 50
        add machine script = /usr/sbin/useradd -d /dev/null -g samba-clients
/bin/false -M %u
        os level = 65
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no
        cups options = raw

        comment = Home Directories
        read only = No
        create mask = 0664
        directory mask = 0775
        browseable = No

        comment = All Printers
        path = /usr/spool/samba
        printable = Yes
        browseable = No

        comment = The HP multifunction printer w. scan and fax capability
        path = /usr/spool/samba
        printer admin = root, lbarnett
        read only = No
        guest ok = Yes
        min print space = 2000
        printable = Yes
        cups options =
        printer name = hp6210
        oplocks = No
        share modes = No

        available = No

        comment = Samba print driver download area
        path = /etc/samba/drivers
        admin users = root, lbarnett
        guest ok = Yes

View this message in context: http://www.nabble.com/Problems-sharing-HP-Officejet-6210-Linux---%3E-XP-tf3556303.html#a9930048
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list