[Samba] windows AD member

Filipe Mota fmota at iportalmais.pt
Thu Sep 28 14:21:25 GMT 2006

Gary Dale wrote:
> Filipe Mota wrote:
>> Hello all,
>>  I have a big problem. I have samba 3.0.23c with ldap backend 
>> configured. On the network, I have windows 2000, windows XP and one 
>> windows 2003 as member of samba domain. Samba runs well until last 
>> weeks when users start problems conectivity with the domain. After 
>> some debug, I discover nmbd stop responding. When I run comand 
>> smbclient to samba server, I have the following respons:
>> session setup failed: Call timed out: server did not respond after 
>> 20000 milliseconds
>> If I restart samba, this work again for some time.
>> First, I think that was appening because I have AD as member of samba 
>> domain, so I put AD in a workgroup. During some days the scenario 
>> works but today the problem come back.
>> What can I do to solve this?
>> thanks,
> I think the basic idea is to recognize that computer software is 
> written by humans and will contain errors. The source of the errors is 
> not always obvious. Therefore system administrators live by the rule 
> "if it ain't broke, don't fix it!"
> The question is, what features do you need in your set up? Normally, a 
> Linux distribution ships with an integrated set of software that is 
> believed to be stable and to work together. You will get bug fixes and 
> security updates for that distribution. You install more recent 
> versions of software at your peril. On a production server, you should 
> only do this if you need a feature that is not working in the version 
> shipped with your distribution (whether it is not there or simply not 
> working properly).
> You have installed 3.0.23c, which is very recent. Nmbd is crashing 
> probably because it doesn't work quite right with other software on 
> your system. Unless you really need something that 3.0.23c provides, I 
> would advise you to downgrade to the version that shipped with your 
> distribution.
> If you do need to run 3.0.23c, or if that is the version that shipped 
> with your distribution, try setting the log level to 10 in smb.conf 
> and see what results you get. Also, check the other logs to see if 
> there some evidence of a problem.

I'm using debian distro as operating system. Before I start to have this 
problem, I haved samba 3.0.14 install from debian distro. Everything 
working for almost 1 year. But I needed to change hardware and I 
reinstalled my server with the same version. The problems start at this 
time. I tried a lot of things to solve this problems, the last one was 
upgrade samba. I tried to set log to level 10 and more but I can see any 
thing. The only conclusion of my debug is when some one try to access to 
AD server trhought samba, nmbd stop respond. But it don't stop at the 
first connect. It's ramdom!! Very strange. I'm not sure if problem is in 
samba server or in AD. I need to use AD server because I have some 
aplication who need to be install on windows. Could be a bug on samba, a 
virus, one of the aplication I use in AD? I don't know...

Does some one have an idea or a scenario like this one?


Filipe Dias da Mota

iPortalMais - Serviços de Internet e Redes, Lda.
TEL: +351 22 510 64 76
GSM: +351 93 449 12 42
FAX: +351 22 518 97 22

More information about the samba mailing list