[Samba] Samba 3.0 build with ADS support on Solaris 9

Neil Muller neil at neologix.net.au
Thu Jun 8 04:09:48 GMT 2006

Hi Jagga,

I have been having a similar problem building samba 3.0.22 with ADS for 
solaris 9. I have tried following instructions from 
http://lists.samba.org/archive/samba/2006-May/120930.html but still get 
errors when smbd is converting from foreground to daemon mode - it just 

My current workaround is to build without ADS support and treat samba 
server as an NT4 server (the ADS domain is a mixed mode domain) so join 
with net rpc join  ... etc and then use a usermap to map domain users 
onto local users as needed. Domain PDCs and BDCs are password server.

However this is only a stop gap until samba + ADS build is sorted out so 
if anyone has any ideas on what is happening or what to do I would 
really appreciate the help.



Jagga Soorma wrote:
> Hey Guys,
> I have trying to build Samba 3.0 with ADS support on Solaris 9.  This is 
> how
> I am trying to configure samba:
> ./configure     --prefix=/usr/local/samba \
>                --with-ldap \
>                --enable-static \
>                --with-ads \
>                --with-krb5 \
>                --with-libiconv \
>                --with-automount
> I have set the LD_LIBRARY_PATH:
> export LD_LIBRARY_PATH="/opt/sfw/lib:/usr/local/lib:/usr/lib"
> ls /opt/sfw/lib
> liblber.a             liblber.so.2          libldap.la
> libldap_r.so          libldap.so
> liblber.la            liblber.so.2.0.122    libldap_r.a
> libldap_r.so.2        libldap.so.2
> liblber.so            libldap.a             libldap_r.la
> libldap_r.so.2.0.122  libldap.so.2.0.122
> The error I am receiving when I run the configure is:
> ..snip
> checking for lber.h... yes
> checking for ber_scanf in -llber... no
> checking for ldap_init in -lldap... no
> checking for ldap_set_rebind_proc... no
> checking whether ldap_set_rebind_proc takes 3 arguments... 3
> configure: error: libldap is needed for LDAP support
> Any ideas what I am missing?  Libldap seems to be there so how come
> configure is not seeing it?
> Any suggestions or comments would be grately appreciated.
> Thanks,
> -Jagga

More information about the samba mailing list