[Samba] Cannot access from Windows...??!! Samba 3.x and FreeBSD 6.0

Bruce Lane kyrrin at bluefeathertech.com
Tue Apr 25 02:49:33 GMT 2006

Fellow Samba folk,

	I'm in the process of resurrecting one of my servers with FreeBSD 6.0/Production, and Samba 3.x (I installed the FreeBSD-obtained package). I'm using 'domain' for the security mode, and the Samba server was successfully joined to my domain.

	It -almost- works. I can see the share from my Windows 2000 system, and browse it. However, I cannot write to it. I keep getting 'Access Denied' from Windows.

	I've tried everything I can think of -- permissions on the share directory on the BSD side, making sure passwords were the same on both systems, using smbpasswd -a to add myself (and a few others) as users, but it's still not working. In fact, it's driving me nuts. This worked just fine with 2.2.8 under NetBSD!

	From Googling around, I found some reference to 'encrypted passwords,' but I didn't specify 'encrypt passwords = no' in smb.conf.

	Part or all of my smb.conf file is available for analysis upon request. Please, someone tell me what I'm doing wrong before I gain back the gray hair I lost thanks to changing jobs!

	Thanks in advance.

Bruce Lane, Owner & Head Hardware Heavy,
Blue Feather Technologies -- http://www.bluefeathertech.com
kyrrin (at) bluefeathertech do/t c=o=m
"If Salvador Dali had owned a computer, would it have been equipped with surreal ports?"

More information about the samba mailing list