[Samba] Samba with AD auth ------(reply from Dgoch)

Daniel Gochenour dgochenour at thielegeotech.com
Thu Nov 10 15:46:45 GMT 2005

The Samba 3.0 server did something very similar here this weekend.  The
machine is a RHEL 3 with all of the updates applied to it before ver. 4 came
out and it was authenticating against a Windows 2000AD for 14 months without
any problems until November 05 2005 and then after a brief reboot on the
machines over the weekend they stopped "talking" to each other.
The problem has been persistent with a handful of users every morning this
week not being able to authenticate to the Linux box.  I wonder if it is
using cached user credentials and not forwarding to the LDAP (AD) server
I will have to wait for the weekend again to take the machine completely off
line to try to track down the bug. 

Does anyone think this has to do with a recent Windows Update?


-----Original Message-----
From: Edward Brookhouse [mailto:ebroo at healthydirections.com] 
Sent: Wednesday, November 09, 2005 1:53 PM
To: samba at lists.samba.org
Subject: [Samba] Samba with AD auth 

I'll apologize in advance cause this is lite on details - but I wanted to
share with the list an issue I ran into and how we fixed it - 

Two days ago my previously working well Samba server which authenticated
it's users via a 2003 AD server stopped authenticating any connection
attempted as //servername/share .

If the user connected as //ip address/share everything worked great -

After many google searches and trolling over the Samba lists - I found a
couple of posts that mention this type of problem, but with no solution.

As a desperate measure I just installed the current CVS tree compiled and
installed - used the same config files - restarted samba and everything is
back to working well.

Specs: Fedora Core 4 - Samba (was 3.0.14a-1 - I think) 3.0.14a-2 

Hope this helps someone -


More information about the samba mailing list