[Samba] net password from OS/2 client

Olivier Eymere olivier_eymere at yahoo.com
Tue May 31 22:41:52 GMT 2005

I am trying to get 'net password ...' to work from an OS/2 client to a Samba
3.1.15 server.  However, I get an Invalid Password error whenever I run net
password.  I am certain that I am providing the correct password.  With
DEBUG_PASSWORD on in the build and tracing set to 100 I ran 'net view
\\server' which authenticates correctly and I ran 'net password user
oldpass netpass' which does not.

Some important factors:
1.  The selected protocol is LANMAN2.1 with either test.  
2.  When running net password the SessionSetup andX request is done
anonymously (the username is blank in the request) but when running net
view the SessionSetup andX does include the username in the request.
3.  In smb_pwd_check_ntlmv1() the Part Password (P16) is the same in both

Then with the failed operation I notice that values logged under 'Password
from Client was |' and 'Value from encryption was |' are different, but
with the successful operation they are the same.  I can also see that the
failed 'net password' is using a different challenge than was specified in
the initial session setup.  I can provide traces and what ever information
needed but I don't know where to go from here.  If someone could point in
the right direction I can look deeper but I've hit the wall in terms of my
knowledge of the SMB protocol.  Does anyone know why Samba is not able to
authenticate the password?  Is there a way to fix it?  


More information about the samba mailing list