[Samba] Samba3 on SCO Openserver

roberto.guerra at tecnoeli.it roberto.guerra at tecnoeli.it
Fri May 20 14:13:11 GMT 2005

Dears Sirs;
I'm tryng to compile and install samba 3.0.14a on a SCO Openserver 5.0.6 server (i want to use some shared printers from MS server2003 on a customer network, but with samba SCO ver 2.2, i can't obtain the authorization from the domain controller to use shared resources), but i'm havig a lot of trouble.

I had dowloaded samba-3.0.14a.tar.gz fro Samba.org.
I had put all the source code in the directory "/local/samba", and i have uncompressed and unzipped all the files using gunzip an tar.
I have installed the development package (SCO) on my machine so now i have cc.
Then i run /local/samba/samba-3.0.14a/source/configure to obtain the Makefile (ad i think it's all OK)
When i run make, i obtain a lot (one for each source file .c) of WARNING like this:

UX:ACOMP:WARNING: "include/vfs.h", line 475: no macro replacement within a string literal

then the linker stop with a fatal error:

Undefined first referenced symbol in file
__unsafe_string_function_usage_here__ smbd/msdfs.o
UX:ld: ERROR: BIN/smbd: fatal error: Symbol referencing errors. no output written to bin/smbd

Can anyone help me please?
Note that i'm not a C or Shell programmer so i don't know what i'm really doing!!!
I think that something is wrong in the compiler directive (./configure?)o in some of the include files (includes.h?) are not good for SCO openserver environment.
Many thank in advance
Roberto Guerra

roberto.guerra at tecnoeli.it

More information about the samba mailing list