AW: [Samba] REPOST No 3 - Browsing Problem on Samba 3.0.14 PLEASE HELP!!!

Christoph Herdeg c.herdeg at
Mon May 9 09:16:51 GMT 2005

Hi Doug

Thank you for answering. Yep - it's quite bizarre...I know. I'd never posted
if it wasn't: sorry, but I wasn't asked. The funny thing is that I can
access the _same_ Samba-Server from every real machine without any problems
and also from the Linux-Host that runs the VMware-boxes. 

Today I upgraded VMware to 5.0, just to give it a try. The result let me at
least recognize that my problem has something to do with VMware: Now I can
no longer access folders three layers deep. I authenticate against and
connect to the share, open a windows-explorer and click on the mapped drive.
I can see the share's contents, but any click anywhere on it makes the
explorer stall for 'bout 1-5 minutes (different). I get the same error-msg
as before the VMware-upgrade.

Some more information:
- My W2K3 Domain Controller is the Master Browser, AD, GP and everything
else working
- DNS is configured correctly and working
- smb.conf sets encrypted passwords, NTLMv2 only, security=Domain,
- Samba 3.0.14a-SerNet-Debian on a Debian Sarge from summer 2004
- all that was working perfectly until an uncertain day two weeks ago

I know this crap sounds strange - but it's my situation here. If I can't get
the problem solved, I'll reinstall the server when Sarge is final (hopefully
it will be final before HURD, they talk 'bout "this may"...). But it was a
pain in da a**, if I wasn't able to find another solution. If you need my
smb.conf, just tell.

Regards, Chris


-----Ursprüngliche Nachricht-----
Von: roamdad at [mailto:roamdad at] 
Gesendet: Sonntag, 8. Mai 2005 19:04
An: c.herdeg at
Cc: samba at
Betreff: Re: [Samba] REPOST No 3 - Browsing Problem on Samba 3.0.14 PLEASE

Christoph Herdeg wrote:

>Hello Experts,
>I have a severe Problem with my current samba installations. Here in my 
>Home-Office networt I have a dual-CPU machine with Debian Sarge, 
>hosting some samba 3.0 shares and as well being a host for 4 
>vmware-sessions (Vmware Workstation v4.52, with 3xServer2003 and 
>1xXPpro). As well I have a separate raid5-server with samba 3.0 in the 
>exakt same configuration (of course all parameters except the hostname
>>From all "real" machines in my network I am able to access all samba 
>without any hassle. 
>But if I try to use a samba share from one of the vmware-machines 
>(which are connected to the network using the "bridged network" 
>config), I will be able to connect to it and to see the three upmost 
>levels of the contained folders and files (like
\\Servername\Sharename\1stLevel\2ndLevel\3rdLevel ).
>But if I then try to access the "3rdLevel"-Folder, it takes minutes and 
>finally gives an error like "no access to 3rdLevel, you eventually 
>don't have the right to access this ressource...bla...bla...The network 
>name is no longer available". This happens if I try to access the share 
>by connecting it to al local driveletter as well when trying to type 
>\\Servername\Sharename to explorer-windows - no difference in behaviour.
>The funny thing is, that I can access the share on the raid5-server 
>without any problems from everywhere.
>Does anyone 'round here experience the same problem and does anyone 
>have a quick solution?
I don't have the problem.
This about my deepest path into Samba version 3.0.15pre2-SVN-build-6319
This is on vmware 4.5.2 build 8848, bridged ethernet, vlance virtual device.
Running a 2003 Enterprise server SP1
linux 2.4.20-28.9smp, basically RH9, kerberos & gcc are homebrew.

Three folders down sounds pretty bizarre.  Maybe you're using the vmxnet
virtual device?  I had some issues with that if my memory serves me
Regards, Doug

More information about the samba mailing list