[Samba] /tmp does not exist or is not a directory

Res res at ausics.net
Wed Apr 13 08:28:42 GMT 2005

OK, no one on this list seen this before than I assume, well it still 
occurs with latest compiled version.

On Mon, 11 Apr 2005, Res wrote:

> Hi All,
> [2005/04/11 11:26:58, 0] smbd/service.c:make_connection_snum(620)
>  '/tmp' does not exist or is not a directory, when connecting to [IPC$]
> This wierd and wacky thing has just started for no apparent reason
> no upgrades were done no system mods were performed, the file server is just 
> never played with except to add shares, testparm says all OK.
> This also happens when a user tries to login, it comes up with the full path 
> saying it doesnt exist or is not a directory, but they do and are...
> Its almost like Samba has lost the plot into what its 'master root' is.
> smbd/service.c:make_connection_snum(620)
> '/home/res' does not exist or is not a directory, when connecting to [res]
> (bit of problem there *IF* my unix login was flapped up, so its fine because 
> logins are ok)
> Google is full of diferent stuff about this and no clear suggestions to wtf 
> it is, and a couple of suggestions of resolutions dont work,
> we have tried a fresh samba conf install,  one working one from another 
> samba server and its fine.
> Version 3.0.9-1.3E.2
> smbclient -L fox -N
> Domain=[HOME] OS=[Unix] Server=[Samba 3.0.9-1.3E.2]
> tree connect failed: NT_STATUS_BAD_NETWORK_NAME
> of note here when smbclient is ran with -d8 is that it says session setup OK 
> ???
> Domain=[HOME] OS=[Unix] Server=[Samba 3.0.9-1.3E.2]
> session setup ok
> write_socket(4,98)
> write_socket(4,98) wrote 98
> size=35
> smb_com=0x75
> smb_rcls=204
> smb_reh=0
> smb_err=49152
> smb_flg=136
> smb_flg2=49153
> smb_tid=0
> smb_pid=9329
> smb_uid=0
> smb_mid=3
> smt_wct=0
> smb_bcc=0
> tree connect failed: NT_STATUS_BAD_NETWORK_NAME
> Other info...
> hosts.allow/deny are fine
> This is also an NFS exports to our primary backups server (has not been an 
> issue before tho)
> Kernel: 2.4.21-27.0.2.EL
> Last Mod time on smb.conf - month ago, known to be working a week ago, the 
> machine lost power, when it came up it still worked, had uptime since then.
> This machine is mainly used for group shares so the backups server has smb on 
> it for a tad whilst we sort this out and the NFS shares allow access to it, 
> but we dont want it to be this way, kind of defeats the purpose of a file 
> server dpoesnt it :) .... so any suggestions muchly appreciated
> Cheers
> Res


More information about the samba mailing list