[Samba] RE: Smbd 3.0.13 dies when smb.conf has winbind separator = \

John H Terpstra jht at samba.org
Sun Apr 3 19:46:47 GMT 2005

On Sunday 03 April 2005 13:28, Greg Scott wrote:
> With help from Doug VanLeuven I think we fixed the problem.  The whole
> bit with the backslash was a dead-end.  Doug sent over this script that
> puts the libnss_winbind.so and libnss_wins.so libraries where they
> belong and sets up working symlinks.  The documentation for moving the
> libraries in section of the Samba-HOWTO-Collection is wrong.
> Use Doug's script instead:

Please file a bug report on https://bugzilla.samba.org with clear information 
regarding what is wrong with the documentation. Please provide an example of 
how we can reproduce the problem and all information that you can offer to 
help correct the defect.

I have tried to check this on several Linux systems and am unable to find a 
problem with the default installation method. The default installation method 
matches what is in the documentation.

The libnss_winbind.so library needs to be in the standard place that is 
searched for by the Name Service Switcher (NSS) on your system. It needs to 
be linked to the version of the nss libraries that you operating system is 
designed to search for.

On Linux  the correct location for this file, together with its symbolic link, 
is in /lib. There is no benefit at all in adding links to the /usr/lib 

Please help to clear up whether or not the documentation really does need 
updating or if in fact your claim that it is incorrect is in itself bogus. 

Winbind does not use the libnss_winbind.so library - that is called only by 
NSS and therefore the location and linkage of the libnss_winbind.so library 
can not have anything to do with why your winbindd may have crashed.

- John T.

> I think I still have some Kerberos work to do, but now I can open the
> shares on this system from a Windows box.
> My next challenge is squid authentication (sigh) . . .
> - Greg
> #!/bin/sh
> # Save this script some place convenient.
> # cd /usr/src/samba-3.0.13/source and run this script from there.
> echo "Copying nsswitch modules to system library"
> CWD=`pwd`
> cd /lib
> rm -f libnss_winbind.so libnss_winbind.so.1 libnss_winbind.so.2
> rm -f libnss_wins.so libnss_wins.so.1 libnss_wins.so.2
> cd /usr/lib
> rm -f libnss_winbind.so libnss_wins.so
> cd $CWD
> cp -f nsswitch/libnss_winbind.so /lib
> cp -f nsswitch/libnss_wins.so /lib
> cd /lib
> ln -sf libnss_winbind.so libnss_winbind.so.1
> ln -sf libnss_winbind.so libnss_winbind.so.2
> ln -sf libnss_wins.so libnss_wins.so.1
> ln -sf libnss_wins.so libnss_wins.so.2
> cd /usr/lib
> ln -sf ../../lib/libnss_winbind.so libnss_winbind.so
> ln -sf ../../lib/libnss_wins.so libnss_wins.so
> /sbin/ldconfig
> -----Original Message-----
> From: Murali Gunasekaran [mailto:mgunase at gce2000.com]
> Sent: Sunday, April 03, 2005 10:26 AM
> To: Greg Scott; samba at lists.samba.org
> Subject: RE: [Samba] RE: Smbd 3.0.13 dies when smb.conf has winbind
> separator = \
> Greg,
> Just a few suggestions:
> 1. Try starting winbind with the options -i and -d <debug-level> like  $
> /usr/sbin/winbindd -i -d 3 This will show what winbind is doing behind
> the covers and possibly show what's wrong.
> 2. Are you able to authenticate using wbinfo -a username%password ?
> 3. I haven't used ADS and have only tried setting security=domain, so
> not sure about Kerberos auth. Have you joined your Samba server as a
> domain member of your Windows PDC? (Check your Active Directory setting
> in your windows PDC)
> 4. Also, make sure your /etc/resolv.conf contains entries to your
> nameserver, like "nameserver <pdc-ip-addr>"
> Murali

John H Terpstra
Samba-Team Member
Phone: +1 (650) 580-8668

The Official Samba-3 HOWTO & Reference Guide, ISBN: 0131453556
Samba-3 by Example, ISBN: 0131472216
Hardening Linux, ISBN: 0072254971
Other books in production.

More information about the samba mailing list