[Samba] files on shared ntfs-disk in linux-pc are not accessible

toffi at muenster.de toffi at muenster.de
Fri Sep 3 12:56:38 GMT 2004


I have spent the entire evening, trying to access a ntfs-drive in my linux-box
from my WinXP-Notebook but I just can't get it to work (and it's 3:50 a.m.

I have put a 160GB harddisk into a linux box (LFS 5.1.1, console only) and
mounted it: 
/dev/hdd1 /mnt/toffi ntfs ro,uid=christoph,gid=christoph,umask=022 0 0 

To check wether the data on the disk is ok, I then put in a Knoppix-Live-CD
(3.6) and opened some of the Video-Files on the disk -> the disk and it's ntfs
filesystem seem to be ok!

I then tried to share this disk using samba, to be able to access it from my
notebook (WinXP): (from my smb.conf)

read only = yes 
browsable = yes 
valid users = christoph 

The linux-pc shows up in my network neighbourhood, as do its shares, including
my ntfs-disk. By double-clicking on 'toffi', I get a listing of the disk's root
However, any further click causes the explorer window to freeze for about two
minutes until a folder is opened or a context menu appears. In the opened
folder, the file-listing often remains blank and if the files are listed, I
cannot open them.
Copying files from the ntfs-disk to my windows-box will result in corrupted
This problem only applies to the ntfs-share. All the other (ReiserFS) shares
work fine!

So I tried to mount the ntfs-share on the server-machine itself:
mount -t smbfs -o username=christoph,password=passwd //linbox/toffi /mnt/test 

The ntfs-disk then gets mounted to /mnt/test and i can browse and list folders
as much as I like but when I try to open a file with less, I get an error
smb_request: result -5, setting invalid 

I did all this as root.

As the files are okay and the problem does not seem to be M$-specific, something
has to be wrong with my Linux-machine.

So I booted from the Knoppix-Disk one more time, mounted the ntfs-disk and
shared it and voilà: I can access any file from my notebook and it's fast! So I
copied the samba-configuration from the Knoppix-disk (at least partly) but that
didn't help either.

Maybe all this has to do with user-rights.. I don't know.. and I really do not
have any idea what I can try..

* P L E A S E * H E L P * M E * 

More information about the samba mailing list