[Samba] samba lock problem

Edilson Carlos Belluomini edilson at maxihelp.com.br
Fri Sep 3 11:34:52 GMT 2004

Helo, i am not a list subscriber, so please send messages to edilson at maxihelp.com.br

Sorry my bad english.

I´m trying to use a Linux box with samba 3.0.4 and one ACUCOBOL application. When I run this application on Windows 98 workstations, it works fine.

When I try to run the same application on a Windows 2000 / XP Workstation or Server, the application starts to run, but it stops working. It appears that it is whaiting for a liberation of a file, because the cursor become an hour-glass and when I start then same application on a Windows 98 workstation at the same option, the Windows 2000 workstation starts to run again, but it stops again (I think that when another workstation locks a file).

I tried to disable oplocks at samba and at Windows 2000, but it don´t solve the problem

When I start running this application whith the data files on a Windows 2000 Server, is works fine.

I am using the above smb.conf:

workgroup = XXXXX
netbios name = yyyyy
server string = Linux SMB Server
large readwrite = yes
max xmit = 65535
dns proxy = no
printing = cups
local master = no
os level = 70
debug level = 1
printcap name = cups
security = user
add machine script = /usr/sbin/adduser -n -r -g machines -c "Samba machine" -d /dev/null -s /bin/false %u
getwd cache = yes
max log size = 50
log file = /var/log/samba/%m.log
read raw = yes
load printers = yes
smb passwd file = /etc/samba/smbpasswd
write raw = yes
deadtime = 15
client use spnego = yes
username map = /etc/samba/smbusers
interfaces =
encrypt passwords = yes
winbind use default domain = no
oplock break wait time = 10
passdb backend = smbpasswd
template shell = /bin/false
wins support = yes
preferred master = no
domain logons = no
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431

path = /var/lib/samba/drivers
guest ok = yes
browseable = yes
read only = yes
write list = root

comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes
printer admin = root

comment = Diretorio do Sistema 
path = /vv/apli
valid users = @vila
public = no
browseable = yes
writable = yes
printable = no
directory mode = 2770
create mask = 0770
create mode = 0770
force create mode = 0770
force directory mode = 2770
force group = vila
# veto oplock files = /*.DAT/*.dat/*.DAD/*.dad/
oplocks = no
level2 oplocks = no
I would appreciate some help.

Edilson Carlos Belluomini
edilson at maxihelp.com.br

More information about the samba mailing list