[Samba] printer giving Access Denied

Ryan Suarez ryan.suarez at sheridanc.on.ca
Tue Oct 5 15:53:52 GMT 2004

Is the samba spool directory the same for both printers?

Andrew Gaffney wrote:

> I have 2 printer queues setup on my samba 3.0.6 NT4-style PDC. About a 
> month ago, one of them stopped working due to an issue with CUPS. 
> After restarting CUPS, printing to that share was giving Access 
> Denied. From a windows box, I was able to add drivers and set default 
> print settings as a domain administrator but I still couldn't print. I 
> created a new printer share pointing at the same CUPS printer with the 
> same configuration and the new one worked.
> In my smb.conf snippet below, the non-working printer share had the 
> same settings as 'jetdirect' but with the printer of 'minimike'. 
> 'jetdirect' has never given me a problem and 'minimike' worked from 
> the moment I created the share. The current 'minimike' settings are 
> scaled down from what it was when I first created it. Can anyone think 
> of a reason why this would happen?
> [jetdirect]
>         printer = jetdirect
>         comment = Hallway printer
>         printable = yes
>         writeable = yes
>         public = yes
>         printer admin = @domainadmins
>         guest ok = yes
> [minimike]
>         printer = hp4200
>         printable = yes
>         read only = no
>         printer admin = @domainadmins

More information about the samba mailing list