[Samba] printer giving Access Denied

Andrew Gaffney agaffney at skylineaero.com
Tue Oct 5 18:31:07 GMT 2004

I didn't specify a spool directory for either so I assume they would both use 
the default.

Ryan Suarez wrote:
> Is the samba spool directory the same for both printers?
> Andrew Gaffney wrote:
>> I have 2 printer queues setup on my samba 3.0.6 NT4-style PDC. About a 
>> month ago, one of them stopped working due to an issue with CUPS. 
>> After restarting CUPS, printing to that share was giving Access 
>> Denied. From a windows box, I was able to add drivers and set default 
>> print settings as a domain administrator but I still couldn't print. I 
>> created a new printer share pointing at the same CUPS printer with the 
>> same configuration and the new one worked.
>> In my smb.conf snippet below, the non-working printer share had the 
>> same settings as 'jetdirect' but with the printer of 'minimike'. 
>> 'jetdirect' has never given me a problem and 'minimike' worked from 
>> the moment I created the share. The current 'minimike' settings are 
>> scaled down from what it was when I first created it. Can anyone think 
>> of a reason why this would happen?
>> [jetdirect]
>>         printer = jetdirect
>>         comment = Hallway printer
>>         printable = yes
>>         writeable = yes
>>         public = yes
>>         printer admin = @domainadmins
>>         guest ok = yes
>> [minimike]
>>         printer = hp4200
>>         printable = yes
>>         read only = no
>>         printer admin = @domainadmins

Andrew Gaffney
Network Administrator
Skyline Aeronautics, LLC.

More information about the samba mailing list