[Samba] Cannot start SWAT on Solaris 8 server - libiconv.so.2: open

Scarff, Christopher J Mr (Titan) 513th Chris.Scarff at mi513.gordon.army.mil
Tue Mar 30 15:57:49 GMT 2004

No one on the planet has seemed to answer this question.  After an hour
or so of trying to fix this problem myself, I now have the answer, at
least a temp fix for it.


I just linked /usr/local/lib/libiconf.so.2 /lib/libiconf.so.2 in Solaris
9. Seems to get Swat working again.  






Original message


I'm having some trouble getting SWAT to run on a Solaris 8 server of
On this server, SWAT is started through inetd:
root_s07nfs:/opt/ > grep swat /etc/inetd.conf
swat    stream  tcp     nowait.400      root
/opt/samba-3.0.0/samba/bin/swat swat
When I go to http://server:901/, I see this in the browser window:
ld.so.1: swat: fatal: libiconv.so.2: open failed: No such file or
I suppose this is because libiconv.so.2 is in /usr/local/lib:
root_s07nfs:/opt/ > ls -la /usr/local/lib/libiconv.so.2
lrwxrwxrwx   1 root     other         17 Sep 30 13:18
/usr/local/lib/libiconv.so.2 -> libiconv.so.2.1.0
-rwxr-xr-x   1 bin      bin      1138992 Jan 27  2003
I guess, this is because /usr/local/lib isn't in a path the dynamical
linker searches when looking for libraries. I tried to add
to this path by running crle:
root_s07nfs:/opt/ > crle
Configuration file [3]: /var/ld/ld.config
  Default Library Path (ELF):
  Trusted Directories (ELF):    /usr/lib/secure  (system default)
Command line:
  crle -c /var/ld/ld.config -l
Even after restarting inetd, login via browser is not possible.
Hm. When I run smbd, the path configured with crle is used for searching
Any ideas how I can get swat to work?
Thanks a lot,
Alexander Skwar
 * We used to try various strange things. Let's not.
        2.2.16 /usr/src/linux/fs/buffer.c


More information about the samba mailing list