[Samba] Domain privileges lost after second logon

Edward Ashley samba at klesknet.com
Wed Mar 10 00:04:50 GMT 2004

I've found out what was wrong. I'll just write out how I solved it for
anybody else as stupid as me.

I used the smbldap scripts provided by idealx, and in the smb.conf I had
an add machine script like this:

add machine script = /usr/local/bin/smbldap-useradd.pl -w %u

But this somehow didn't add the computer to the Domain Computers group
that I have in the LDAP database.

Therefore I just manually added the computers to that group and everything
works now. I will start to look into which script I have to change for
this to become automatic when adding computers to the domain.


> Hi,
> I'm hoping someone will help me fix an annoying problem.
> I have a Redhat fedora core 1 machine, with the stock installation of
> samba
> acting as a primary domain controller. I'm using an LDAP backend, and I'm
> not using any mandatory profiles.
> When someone logs into a newly booted winXP or w2k machine, everything
> works
> fine. The groups are there and everybody has their correct privileges. But
> if the user logs out and back in, then all the privileges are taken away
> and
> the user is treated like a guest. I can't even check whether the groups
> are
> still mappedto the workstation as I don't have the privileges.
> If this makes sense to anyone, and they know what is wrong with my samba
> setup, can they please help.
> Many thanks
> Ned
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list