[Samba] Access97, in house VB6 app, terrible performance

Tim Smith tims at cqpl.com.au
Wed Jan 28 10:35:46 GMT 2004

Andrew Bartlett wrote:

>On Wed, 2004-01-28 at 10:49, Tim Smith wrote:
>>hello everyone I am running suse9.0 with samba 2.2.8 kernel 2.4.23, the 
>>app is in vb6 using the vb jetengine to access access97 databases, 
>>roughly 15 of them all between 200 - 900 megs in size, all on the same 
>>shared drive.
>>This arrangement works well on our NT4 server. but when we try to use 
>>linux/samba we find read/writing is incrediably slow. as an example our 
>>standard test on NT4 takes 4 -5 seconds to run. Now, with 6 workstations 
>>connected under samba this test also takes 4 - 5 seconds, BUT as soon as 
>>the entire lab is connected which is roughly 30 - 40 pc's, that time 
>>jumps to 20 - 30 seconds.
>>Now here is what we have tried:
>>standard samba install, oplocks are at defaults. very very slow performance.
>>we have also tried vetto oplocks, seemed to have no affect.
>>after much fiddling with socket options, log levels and much reading on 
>>how oplocks work we discovered if "fake oplocks = yes" was set our 
>>performance issues vanished.
>And so did all your database integrity!
>What syntax were you using for 'veto oplock files'?
>You could just turn off oplocks completely 'oplocks = no'.
>Andrew Bartlett
our database integrity sure did vanish. i was  under the impression the 
the .ldb file did the locking for  the access files... but aparantly not.
funny thing is oplocks = no didn't work either.
for veto oplocks i user "veto oplocks =  /dir/*.*db" so that all 
database files on our system we not locked.
I have read plenty of documentation that states database files should 
NOT be locked.

More information about the samba mailing list