[Samba] Access97, in house VB6 app, terrible performance

Andrew Bartlett abartlet at samba.org
Wed Jan 28 07:57:34 GMT 2004

On Wed, 2004-01-28 at 10:49, Tim Smith wrote:
> hello everyone I am running suse9.0 with samba 2.2.8 kernel 2.4.23, the 
> app is in vb6 using the vb jetengine to access access97 databases, 
> roughly 15 of them all between 200 - 900 megs in size, all on the same 
> shared drive.
> This arrangement works well on our NT4 server. but when we try to use 
> linux/samba we find read/writing is incrediably slow. as an example our 
> standard test on NT4 takes 4 -5 seconds to run. Now, with 6 workstations 
> connected under samba this test also takes 4 - 5 seconds, BUT as soon as 
> the entire lab is connected which is roughly 30 - 40 pc's, that time 
> jumps to 20 - 30 seconds.
> Now here is what we have tried:
> standard samba install, oplocks are at defaults. very very slow performance.
> we have also tried vetto oplocks, seemed to have no affect.
> after much fiddling with socket options, log levels and much reading on 
> how oplocks work we discovered if "fake oplocks = yes" was set our 
> performance issues vanished.

And so did all your database integrity!

What syntax were you using for 'veto oplock files'?

You could just turn off oplocks completely 'oplocks = no'.

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20040128/af2360d1/attachment.bin

More information about the samba mailing list