[Samba] Problems with WIN2K accessing Samba 3.0.1 as PDC

Matt matt at breathethis.com
Tue Jan 6 16:34:47 GMT 2004


I am almost at the end of my rope right now. Here is the deal. I initially
installed Redhat 7.1 with the version of Samba server is came with (2.0.7 or
something) I setup everything fine, but when it came to setting the machine
up as a PDC, I recieved an error that could be fixed by a patch.

Instead, I decide to re-install RH 7.1 without Samba, and get the latest
distro. I download 3.0.1 and install. Once again P2P networking works fine,
but when I get to PDC again... This time, All I get is Login Error: Username
is invalid and or bad password. I have all of the required files with
/usr/local/samba/lib/smpasswd, /etc/passwd with all of the right information
including a Machine account for the WIN2K PC. It is all formatted properly.
The error in the NMBD log repeats itself like 12 times with a code 0x12
whenever I try to login. I have literally gone through EVERY "HOWTO - Samba
PDC" on the internet, and can't get it figured out!

When I punch in root and type the wrong password, it gives me the error
right away, yet when I key in the right password, the drive lights on both
machines start and about 10 seconds later is gives me the error.

To add fuel to the fire, I have tried this with

RedHat 7.1
Slackware 9.1
Debian 3.0 Rev2
Mandrake (newest release)

Same error. So it ain't my Linux.

Anyone... please?

More information about the samba mailing list