[Samba] Win2k and Printing

Martin Fluch fluch at rock.helsinki.fi
Fri Mar 14 21:08:59 GMT 2003


I'm trying now already for a couple of weeks to get around a strange
problem. I have configured on a Debian machine Samba server ("Version
2.999+3.0.alpha21-5 for Debian") mainly for acting as a print server in my
dormitrory. The config file looks like:

        workgroup = VYOKATU
        server string = %h server (Samba %v)
        security = SHARE
        passdb backend = tdbsam, unixsam
        printcap name = cups
        panic action = /usr/share/samba/panic-action %d
        printing = cups

        comment = Home Directories
        read only = No
        create mask = 0700
        directory mask = 0700

        comment = All Printers
        path = /var/tmp
        guest ok = Yes
        printable = Yes
        browseable = No

We have one Win98 and two Win2k machines, the first one has no problems.
With the Win2k I can print but I canot access the printing queue: I get
always the message "Unable to connect: Access denied." message when I try
to open the queue window. This hapened with the LPRNG system I have tried
and now also with the CUPS printing system.

I tried first "simple" things like sharing directories and that is no
problem, authentication seems to work as well (I can write on my home
directory but not the others users home directory), I can print but not
access the queue. Darn.

I tried to do look in the web for an answer, and it seems that this issue
is not uncommon, but somehow I didn't find the right hint sofar.

Anybody an idea where to look for the answer?

Thanxs in advance,
- Martin

More information about the samba mailing list