[Samba] Win XP-home connecting to Samba, ahhh, please help!

Mark Brodis fj40rockcrawler at yahoo.com
Fri Mar 7 22:46:43 GMT 2003

I'm about ready to pull my teeth out over this.  I just installed Red
Hat 8.0, have not used Linux much in the past, which is why I went with
Red Hat, sposeto be easier, more support etc.

The network the Linux box resides in has 2 WinXP-home computers, and a
Win200 Pro computer.  They are all sharing all files, no passwords, no
domain, just a workgroup called "ESR".

I just want the Linux computer to be able to be seen on the network,
and copy/move files freely around on it and others.  I can see the
Windows computers from the Linux box just fine, connect to shares, etc.
 But from the Windows computers the best I've done is I can see the
Linux computer sometimes, rarely, I can never access it, if I even
click on it in Windows it will time-out and say that network resource
can not be found.

I have tried every "general purpose" smb.conf file I can find on the
Internet, usually with different workgroup names, so I can see when the
Windows computers sees the new workgroup, however, I have yet to ever
be able to see the Linux computer under any of the new workgroups, even
clicking on the new workgroup ends up timing out and saying it can't
find that network resource.  Ahhhhh, so you see the frustration!

I have gone through the smb.conf file about 100 times, trying different
options, turning others off, absolutely nothing has helped.  I tried to
use the SWAT config tool, however that isn't available for Samba 2.2.5
apparently, which is what shipped with RH 8.0.  I am downloading 2.2.7
now but if I can't get this working, why think I can get 2.2.7 working.

So, any help would be appreciated, currently this is my
'/etc/samba/smb.conf' file:

[root at localhost samba]# more smb.conf
workgroup = HOME_1
server string = Samba Server
netbios name = linuxbox
hosts allow =
security = share
smb passwd file = /etc/samba/smbpasswd

guest ok = yes
guest only = yes
guest account = ftp
path = /tmp
writeable = yes

guest ok = yes
guest only = yes
guest account = ftp
path = /root
writeable = yes

With the above file as my smb.conf file, in the WinXP-home computers, I
can see the workgroups 'HOME_1', but if I click on it to see any
computers in it, it'll time-out and then just say the network path was
not found, you might not have permission, etc...the WinXP computer I'm
testing this on has a IP of '', the Linux box has a IP of (I added that in the file thinking it might help,

So any help would be GREATLY appreciated.  I'm definetly not a Linux
experienced user, and proving that every second now.

Feel free to e-mail me directly.

Mark Brodis
fj40rockcrawler at yahoo.com

Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more

More information about the samba mailing list