[Samba] Problems compiling samba3.0.0 beta3

Garrott, Brad M. garrottb at timken.com
Tue Jul 29 11:39:43 GMT 2003

I am having problems getting samba 3.0.0 working on my HP server.

I found that I needed to install iconv and openldap, which I did.  However,
when I 
compile and link Samba it still tells me I do not have enough iconv support
check this
specific website.  I pulled the iconv software from this website and
compiled in on my
HP server, but still have the same error.  When I run Samba after compiling
it I get the
following error messages: Error loading module
Can't open shared library: /usr/local/samba/lib/charset/roman8.sl
[2003/07/25 13:09:50, 0] lib/module.c:(40)
  Error loading module '/usr/local/samba/lib/charset/CP850.sl': 
Can't open shared library: /usr/local/samba/lib/charset/CP850.sl
[2003/07/25 13:09:50, 0] lib/charcnv.c:(133)

Is it possible that I have the iconv software installed in the wrong
location and when I 
compile samba it just cannot locate the software.  It is currently in

Brad Garrott

This message and any attachments are intended for the 
individual or entity named above. If you are not the intended
recipient, please do not forward, copy, print, use or disclose this 
communication to others; also please notify the sender by 
replying to this message, and then delete it from your system. 

The Timken Company

More information about the samba mailing list