[Samba] Re: I've always HATED printing with Samba

Dragan Krnic dkrnic at lycos.com
Tue Jul 29 10:51:27 GMT 2003

>>However, you must assure that the mechanism
>>for depositing the client drivers with samba does
>>work without errors. The keywords are rpcclient
>>and cupsaddsmb.

>Tried this:
>[root at enigma root]# cupsaddsmb -a -H localhost 
>Password for root required to access localhost via SAMBA:
>Running command: smbclient //localhost/print\$ -N -U'root%********' -c 
>error connecting to (Connection refused)
>Error connecting to (Connection refused)
>Connection to localhost failed
>Connection refused???

Yes, if you've added "bind interfaces only" or similar.

>Oh well, at least I now know where the drivers are 
>supposed to be at. I also tried this with the 
>firewall down, just in case.  It shouldn't be the 
>firewal though because the only rules I've set are 
>for eth0.
>Also check this out:
>[root at enigma root]# ls /usr/share/cups/drivers/*
>ls: /usr/share/cups/drivers/*: 
>     No such file or directory
>[root at enigma cups]# pwd
>[root at enigma cups]# ls
>banners/ calibrate.ppm charsets/ data/ fonts/  
>model/ templates/

Which part you don't understand? That ls can't list
"/usr/share/cups/drives/*" when the subdir "drivers"
in "/usr/share/cups" isn't there at all? The command 
that should have created it ("cupsaddsmb") failed. 
It's possible that you have to create the directory
manually. Read all about it at Kurt Pfeiffle, ibidem.

>>By the way, what's your distro, release, kernel, >>samba, cups, etc. ?

>Mandrake 9.1 cups Samba 2.2.8 / 3.0b3 (experimental).  Stock kernel.

What do you mean "cups Samba 2.2.8 / 3.0b3". There is
no such thing. cups must be something like 1.1.19 and
samba can be either 2.2.8 or 3.0b3. The problem I
referred to in a previous mail shouldn't affect 3.0b3
but will almost certainly be a nuisance in 2.2.8.

Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!

More information about the samba mailing list