[Samba] Win2K sp4 can't print

Van Sickler, Jim vansickj-eodc at kaman.com
Thu Jul 24 14:33:49 GMT 2003

> -----Original Message-----
> From: Chuck Stuettgen [mailto:cstuettgen at myrealbox.com]
> Sent: Wednesday, July 23, 2003 9:22 PM
> To: Van Sickler, Jim
> Subject: RE: [Samba] Win2K sp4 can't print
> On Wed, 2003-07-23 at 21:32, Van Sickler, Jim wrote:
> > Bob,
> > 
> >   I've upgraded several systems here to SP4,
> > and haven't run into any of these errors (yet!).
> > 
> > However...
> > 
> >   Spoolss was updated in SP4;  I'd try deleting
> > the printers & their ports on the SP4 PCs, then
> > adding them again.  If you toggled or added the
> > "disable spoolss = yes" setting, or upgraded
> > to 2.2.8a after the ports on the win2k PCs
> > were created, it may cause the "Access Denied" error.
> "disable spoolss = yes" didn't fix the "Access Denied" error for my
> w2ksp3 clients. (haven't tried sp4 yet)
> "use client driver = yes" gets rid of the "Access Denied" error but I
> now get "....error opening, retrying" message and the print 
> jobs are not
> displayed in the print queue.  But, I'm still working it.. 
> >   Are you setting the printers up as Network or
> > Local on the PCs?  It makes a difference.  Local gave
> > me fewer problems.  Use  \\server\printshare as the
> > port name.
> Could you tell me how you set a UNC as a port without using 
> the Network
> option in the printer setup wizard?
> How do you add it as new port?

Start, Settings, Printers, Add Printer, Local Printer,
Next, Create a New Port; Type:  Local Port, enter the
UNC for the Samba share as the Port Name.  Done!
NOTE:  The share has to exist in order to add it. You'll
get a "Not Found" error if it doesn't.

> >   To be honest, I've pretty much given up on printing in
> > Samba 2.x, and gone over to Standard TCP/IP Ports, printing
> > to the lprng daemon on the Samba server.  I posted a whole
> > bunch of times trying to get a way to enumerate the correct
> > print job info on the clients, instead of the smbprn.xxx.xxx
> > that is usually available.  I never got a solution...
> > 
> I'm using the stock RH 8.0 Samba 2.2.5-10 and LPRng 3.8.9-6.
> It took me a few days of google searches before I finally found this..
> Add the -U%U -J"%J" parameters to get lpq to display the document name
> instead of smbprn.xxxxxx.xxxxx. This works for both W2k and W9x
> clients.  The quotes around the %J are required.
> Mine looks like this:
> print command = lpr -P%p -U%U -J"%J" -r %s
I'll give that a try and see what's displayed.

> Be aware of one oddity, on our w2k clients with the Novell Netware
> client installed, if the user is logged in the local 
> workstation account
> as administrator and the Novell account as his regular account, print
> jobs will show up with the name as "Remote Download Document" 
> instead of
> the real document name. If you create a local workstation account that
> matches the Novell user account and have the user use that 
> instead, then
> the print jobs will display the correct document name. 

All of my users are admin's on their PCs, and log onto the PC
with their Domain user account.  They also display "Remote
Downlevel Document" instead of the file name.  No Novell
client installed.  No local accounts.
> I haven't done any further testing of this, we don't have a Windows
> domain and I haven't tried removing the Novell client and 
> printing so I
> don't know if it Microsoft or Novell bug. 
> -- 
> Like the dinosaur, Windows on the desktop is destined to
> become extinct...
> Chuck Stuettgen cstuettgen at myrealbox.com
> http://www.cfs-tech.homelinux.net

More information about the samba mailing list