[Samba] Samba 3 as a PDC

Jason C. Waters jwaters at h2os.com
Thu Jul 24 02:58:13 GMT 2003

I need help.  I must be doing something wrong.  I'm trying to give all 
domain users power user rights on the workstation machines.  I though by 
adding "Domain Users" to the Power Users group on the local machines 
that it would work, but it doesn't.  I've tried adding the users instead 
of the "Domain Users" group, and everything else I could think of.  This 
is my configuration file:

netbios name = meserver
passdb backend = smbpasswd
workgroup = MVERT
server string = Marysville PDC
load printers = no
log file = /usr/local/samba/var/log.%m
max log size = 500
security = user
#password server =
encrypt passwords = yes
socket options = TCP_NODELAY
local master = yes
os level = 64
domain master = yes
preferred master = yes
domain logons = yes
#wins support = yes
wins server =
locking = no
level2 oplocks = no
oplocks = no
logon script = logon.bat
logon path = \\mvserver\Profiles\%U
logon home = \\mvserver\Secure\%U

        comment = Network Logon Service
        path = /mnt/pub/netlogon
        read only = no
        write list = ntadmin
        comment = BRT Domain User Profiles
        browseable = no
        writeable = yes
        path = /mnt/pub/profiles
        create mask             = 600
        directory mask          = 700

        comment = User Home Directory
        path = /mnt/pub/Staff Directories
        read only = No
        browseable = No

        path = /mnt/pub/E
        writable        = yes
        read only = No
        force create mode = 666
        locking = false
        level2 oplocks = false
        oplocks = false
        path = /mnt/pub/F
        read only = No

I don't care if I need to use samba 2.2, I just don't want to have to 
use NT4, or 2000.  The workstations can join the domain without a 
problem and browse the shares.  But it doesn't have power user 
permission on the local workstations.  I even tried adding a local user, 
then adding that user to the power user group, and loging in locally to 
make sure the Power User group or the default security permissions are 
correct.  It did work.  So now I'm asking for help, because I'm out of 
ideas.  Thanks


More information about the samba mailing list