[Samba] rpcclient / adddriver returns WERR_ACCESS_DENIED

Kurt Pfeifle kpfeifle at danka.de
Tue Dec 9 13:10:45 GMT 2003

Arnst, Rainer wrote:

> Am Die, den 09.12.2003 schrieb Kurt Pfeifle um 12:58:
>>This error typically occurs, if you haven't any driver files waiting
>>to be "adddriver-ed", laying in "[print$]/W32/X86/"
>>Once you run "rpcclient....adddriver", and it fails, you will have to
>>re-assure that *all* the original files are still in place. (A partially
>>succeeding "adddriver" may have moved the files already to the "2" or
>>"3" subdirectories!
> I already moved the files into the subdirs 2 and 3 myself... oops. Thank
> you.

I guessed so.

>>But your description is not clear at all. On the one hand you say you
>>had used the "APW", on the other you are quoting the "rpcclient...
>>...adddriver" command in isolation.
> I had tried the APW-Approach first of all, following the step-by-step
> guide from the howto, but could not get windows to behave like described
> in the How-To.

Did you also change the "writeable = yes" setting in the [printers]
section, as I adviced in my previous posting?

> Then I tried the other approach given. The rpcclient
> command was not an isolated action.
> Thank you very much again. I hope I can get it to work now.
> Greetings,
> Rainer

More information about the samba mailing list